Atom won't open - Windows 10 - Python


#1

Hi all,

I’m confused - already tried multiple reïnstalls / software recovery to yesterday (worked fine then)

I’m getting the current error:

Full text:

Error: EPERM: operation not permitted, open 'C:\Users\bjhja.atom\compile-cache\less\40e22529c8729b65e1d700a7ae3f73d57ed1288f\imports.json’
at Object.fs.openSync (fs.js:558:18)
at Object.module.(anonymous function) [as openSync] (ELECTRON_ASAR.js:173:20)
at Object.fs.writeFileSync (fs.js:1233:33)
at Proxy.writeFileSync (C:\Users\bjhja\AppData\Local\atom\app-1.20.0\resources\app\node_modules\fs-plus\lib\fs-plus.js:298:29)
at LessCache.module.exports.LessCache.writeJson (C:\Users\bjhja\AppData\Local\atom\app-1.20.0\resources\app\node_modules\less-cache\lib\less-cache.js:212:23)
at LessCache.module.exports.LessCache.setImportPaths (C:\Users\bjhja\AppData\Local\atom\app-1.20.0\resources\app\node_modules\less-cache\lib\less-cache.js:161:18)
at new LessCache (C:\Users\bjhja\AppData\Local\atom\app-1.20.0\resources\app\node_modules\less-cache\lib\less-cache.js:68:18)
at new LessCompileCache (C:\Users\bjhja\AppData\Local\atom\app-1.20.0\resources\app\src\less-compile-cache.js:21:26)
at ThemeManager.module.exports.ThemeManager.loadLessStylesheet (C:\Users\bjhja\AppData\Local\atom\app-1.20.0\resources\app\src\theme-manager.js:283:32)
at ThemeManager.module.exports.ThemeManager.loadStylesheet (C:\Users\bjhja\AppData\Local\atom\app-1.20.0\resources\app\src\theme-manager.js:271:27)
at ThemeManager.module.exports.ThemeManager.requireStylesheet (C:\Users\bjhja\AppData\Local\atom\app-1.20.0\resources\app\src\theme-manager.js:191:30)
at ThemeManager.module.exports.ThemeManager.reloadBaseStylesheets (C:\Users\bjhja\AppData\Local\atom\app-1.20.0\resources\app\src\theme-manager.js:252:25)
at ThemeManager.module.exports.ThemeManager.loadBaseStylesheets (C:\Users\bjhja\AppData\Local\atom\app-1.20.0\resources\app\src\theme-manager.js:248:25)
at AtomEnvironment.module.exports.AtomEnvironment.initialize (C:\Users\bjhja\AppData\Local\atom\app-1.20.0\resources\app\src\atom-environment.js:339:25)
at module.exports (C:\Users\bjhja\AppData\Local\atom\app-1.20.0\resources\app\src\initialize-application-window.js:106:29)
at setupWindow (file:///C:/Users/bjhja/AppData/Local/atom/app-1.20.0/resources/app/static/index.js:106:12)
at window.onload (file:///C:/Users/bjhja/AppData/Local/atom/app-1.20.0/resources/app/static/index.js:67:9)
handleSetupError @ index.js:87

Could someone be of assistance?

Thanks!


#2

Try opening atom with --safe flag to figure out if this is a side effect caused by a 3party package.

atom --safe

Also have a look at this
http://flight-manual.atom.io/hacking-atom/sections/debugging/


#3

Sorry, should have mentioned. atom --safe gives me the exact same view sadly.


#4

Weird, try the Reset to Factory Defaults.
Remember to back-up your config & packages.
eg
rename %USERPROFILE%\.atom .atom-backup

http://flight-manual.atom.io/hacking-atom/sections/debugging/#reset-to-factory-defaults

If this works something on your current configuration causes it.


#5

That solved it! Thanks a lot @serafeimgr!