Atom Won't Open on Ubuntu 16.04.1


After using atom for a few months, I now cannot get it to open. I’ve followed the debugging guide, running atom in safe mode, clearing the saved state, uninstalling atom and reinstalling it without any success.

This happened immediately after I uninstalled xubuntu and xfce packages from my Ubuntu install. I’m running Ubuntu 16.04.1 LTS. The version of atom is 1.9.8. The command I used was:

sudo apt-get autoremove --purge xubuntu-* && sudo apt-get autoremove --purge xfce*

A picture of what happens when I try to open atom:


Did you try resetting to factory defaults as described here?



Thanks for responding. I did do the factory reset by starting a new .atom file. I’ve also cleared the saved state, run with --safe, and uninstalled through apt-get.

I’m not an expert, but I think the problem is tied to removing all the xubuntu and xfce packages. I’m wondering if atom has some dependencies that can’t aren’t being recognized with aptitude when I run sudo apt-get -f install. It might be completely a systems problem on my end, but atom is the only program that seems to be affected.


Now it crashes with an error message. I’ve taken screenshots because Ubuntu won’t let me just copy the text out of the error dialog:


Have you tried building from source?


I haven’t. I’ll do that and see if it helps.


Rebuilding from source creates the same issue where all that pops up is the black and gray screen (the first picture I uploaded above shows what it looks like).


I’ve tried running Atom 1.9.8 on Ubuntu 14.04 as well as LMDE 2 (Betsy) and I’m seeing these same symptoms. I’m only using Ubuntu and LMDE inside VirtualBox and haven’t tried Atom non-virtualized. I don’t know if that makes a difference. At least Atom 1.4.3 used to work fine in Ubuntu 14.04 inside VirtualBox.

I’m no expert, but I don’t think the issue is related to missing Xubuntu/Xfce dependencies, because in Ubuntu, the symptoms are the same in the Unity and Xfce desktops.

In LMDE2/Cinnamon, the black/grey contents of the window stay put on the screen, covering every other window. Minimizing Atom only causes the window frame to disappear.

Sometimes when I close Atom, at least in Ubuntu/Xfce, I get a crash similar to post #4 above.

The --safe and --clear-window-state parameters don’t seem to help. I’m getting the black/grey window from a fresh install of Atom.


I am also running in VirtualBox. I created a completely new installation of Ubuntu Mate, installed atom on the brand new OS, and got the same crash.


I am experiencing exactly the same problem. xubuntu 16.04.1 as virtualbox vm. I love using atom but since the upgrade its unusable.


I’m having the exact same crash with Ubuntu 16.04.1 running in VirtualBox, it freezes the machine instantly on launching Atom.

The problem persists only in VirtualBox, Atom runs normally on a native Ubuntu 16.04.1.


I’ve posted the issue on github.


I suspected that this might be a performance related issue so I tried tweaking the settings of the virtual machine, making more RAM, CPU or VRAM for Display available and the result was the same.

Finally, I tried turning 3D acceleration off in VirtualBox settings and that solved the problem instantly for me. Could you confirm this @tmcothran?

VM Issue with Ubuntu using 3D acceleration

You’re right; the problem goes away with 3d acceleration turned off. Wonder if this is an Atom problem or a VirtualBox problem.


Looks like I spoke too soon. Atom will open without the black screen, but will crash with the SIGSEV fault a few minutes later.


After using it for a while I also had a crash. Also, I’ve noticed that sometimes when you close Atom it crashes while ending the process. We can conclude that disabling 3D accelaration is only good for getting Atom running. But it continues to crash and behaves very strangely in a VirtualBox Ubuntu environment. I really don’t know how we can solve this.


VirtualBox recently pushed an update (5.1.4) that seems to have fixed the issue for me. @flippybird, want to try to see if that fixes it for you?


I have VirtualBox 5.1.4 running a Lubuntu guest, and I have the same problem when 3D acceleration is turned on - Atom is just a black screen with some white flickering areas. Seems to be a VirtualBox bug.


Same problem with with 3d acceleration turned on in Ubuntu 16.10 as virtualbox vm. I tried
$ atom --disable-gpu
which seems to work fine. Found this because of the same issue also with Visual Studio Code -
"The Electron shell used by Visual Studio Code has trouble with some GPU (graphics processing unit) hardware acceleration. If VS Code is displaying a blank (empty) main window, you can try disabling GPU acceleration when launching VS Code by adding the Electron --disable-gpu command line switch."


This fix $ atom --disable-gpu appears to fix the problem for me. However, I have not used Atom for any significant amount of time yet, so we shall see if the fix holds up under normal conditions of use.

My problem was the same/similar with Atom v1.13.1 on Xubuntu 16.04 virtual machine via Virtualbox version 5.0.30 r112061 on Windows 7 host machine. Atom installed and launched OK, but the window wais all black, except for the title bar which displayed correctly. The other interesting thing was that the black part of the window did not obey the normal foreground/background window positioning behavior, so that the black part was always on top of everything.