Atom won't open nor install


#1

Hello there! I’m a c.e. student, and I’m mainly using Atom as a C compilter.

Here’s my issue:
Some days ago I used atom to finish a project, saved as usual and shut down the pc. When I went to lesson, one hour later, I couldn’t open the program again. Nothing appeared at all.

What I already tried:
I tried to run the troubleshoot, and to change the compatibily mode, both failed. I went checking the Task Manager, and I noticed this:

So what I did was ending all the processes and restart Atom. Same thing as before.
I restarted my pc, and got no result.
I googled everything and I found a similar issue for an older version of atom, and the suggested solution was to uninstall program, manually delete the folders in %appdata% and then reinstall it. Aaand that didn’t work.
Last hope I had was to restore my pc in a past date when Atom was working, and guess what: that didn’t work.

Now that I ran out of ideas, I’m asking you guys to kindly help me. I badly need this program.

PC Specs:
Acer Notebook Swift 3 SF315-41-R03D
Windows 10 Home
CPU: AMD Ryzen 5 2500U
RAM: 8 GB DDR4
SSD: 256 GB Intel PCIe
GPU: Radeon Vega 1100 MHz


#2

Have you tried renaming the .atom/ folder in your user directory and then restarting Atom? Have you tried starting Atom from the command line with atom --safe and atom --clear-window-state? (If it works the first time, the second command isn’t necessary; the second command will cause the deletion of any unsaved files you have in the process of cleaning out stuff that sometimes causes Atom to not load.)


#3

That worked ^^
Thanks a lot!


#4

No problem. It’s difficult to tell exactly what went wrong, but there are a couple of functions in Atom’s state-saving and restore process that periodically run into difficulties. I’ve used Atom pretty much daily for years and had to deal with this a small handful of times and it comes up on the forum now and again. If you see it again, it’s safe to go into .atom/ and delete all of the folders in there except for dev/ and packages/ and that should do it.