Atom won't open from command line or launcher


#1

Atom was working fine yesterday. I opened it again this evening but no window came up. It froze in the opening process. I tried rebooting my computer, uninstalling and reinstalling ( I had 1.0.8, on 1.0.19 now) and none of that worked. When I type atom -t I get:

[6949:1007/185026:ERROR:browser_main_loop.cc(173)] Running without the SUID sandbox! See https://code.google.com/p/chromium/wiki/LinuxSUIDSandboxDevelopment for more information on developing with the sandbox on.
[6949:1007/185027:WARNING:accelerator_util.cc(185)] Invalid accelerator token: command
[6949:1007/185027:WARNING:accelerator_util.cc(185)] Invalid accelerator token: command
[6949:1007/185027:WARNING:accelerator_util.cc(185)] Invalid accelerator token: command
[6949:1007/185027:WARNING:accelerator_util.cc(185)] Invalid accelerator token: command
[6980:1007/185027:INFO:renderer_main.cc(200)] Renderer process started
[6949:1007/185027:WARNING:accelerator_util.cc(185)] Invalid accelerator token: command
[6949:1007/185027:WARNING:accelerator_util.cc(185)] Invalid accelerator token: command
[6949:1007/185027:WARNING:accelerator_util.cc(185)] Invalid accelerator token: command
[6949:1007/185027:WARNING:accelerator_util.cc(185)] Invalid accelerator token: command
[6949:1007/185027:INFO:CONSOLE(46)] "Window load time: 677ms", source: file:///usr/share/atom/resources/app.asar/static/index.js (46)

If I just type atom in the terminal I get the following:

~/usr/bin/atom: line 91: /home/user/.atom/nohup.out: Permission denied
[2188:0907/173851:ERROR:browser_main_loop.cc(170)] Running without the SUID sandbox! See https://code.google.com/p/chromium/wiki/LinuxSUIDSandboxDevelopment for more information on developing with the sandbox on.
Arguments to path.join must be strings
Error reading compiled file TypeError: Arguments to path.join must be strings
    at Object.posix.join (path.js:449:13)
    at readCachedJavascript (/usr/share/atom/resources/app.asar/src/compile-cache.js:81:24)
    at require.install.retrieveSourceMap (/usr/share/atom/resources/app.asar/src/compile-cache.js:125:22)
    at mapSourcePosition (/usr/share/atom/resources/app.asar/node_modules/source-map-support/source-map-support.js:132:21)
    at wrapCallSite (/usr/share/atom/resources/app.asar/node_modules/source-map-support/source-map-support.js:295:20)
    at /usr/share/atom/resources/app.asar/node_modules/source-map-support/source-map-support.js:330:26
    at Array.map (native)
    at Function.prepareStackTrace (/usr/share/atom/resources/app.asar/node_modules/source-map-support/source-map-support.js:329:24)
    at process.<anonymous> (/usr/share/atom/resources/app.asar/src/browser/main.js:29:14)
    at emitOne (events.js:82:20)
Error reading compiled file TypeError: Arguments to path.join must be strings
    at Object.posix.join (path.js:449:13)
    at readCachedJavascript (/usr/share/atom/resources/app.asar/src/compile-cache.js:81:24)
    at require.install.retrieveSourceMap (/usr/share/atom/resources/app.asar/src/compile-cache.js:125:22)
    at mapSourcePosition (/usr/share/atom/resources/app.asar/node_modules/source-map-support/source-map-support.js:132:21)
    at wrapCallSite (/usr/share/atom/resources/app.asar/node_modules/source-map-support/source-map-support.js:295:20)
    at /usr/share/atom/resources/app.asar/node_modules/source-map-support/source-map-support.js:330:26
    at Array.map (native)
    at Function.prepareStackTrace (/usr/share/atom/resources/app.asar/node_modules/source-map-support/source-map-support.js:329:24)
    at process.<anonymous> (/usr/share/atom/resources/app.asar/src/browser/main.js:29:14)
    at emitOne (events.js:82:20)
TypeError: Arguments to path.join must be strings
    at Object.posix.join (path.js:449:13)
    at Object.exports.setAtomHomeDirectory (/usr/share/atom/resources/app.asar/src/compile-cache.js:19:21)
    at setupCompileCache (/usr/share/atom/resources/app.asar/src/browser/main.js:116:25)
    at start (/usr/share/atom/resources/app.asar/src/browser/main.js:37:5)
    at Object.<anonymous> (/usr/share/atom/resources/app.asar/src/browser/main.js:206:3)
    at Object.<anonymous> (/usr/share/atom/resources/app.asar/src/browser/main.js:208:4)
    at Module._compile (module.js:452:26)
    at Object.Module._extensions..js (module.js:470:10)
    at Module.load (module.js:347:32)
    at Function.Module._load (module.js:302:12)
ATTENTION: default value of option force_s3tc_enable overridden by environment.

Not really sure what to do, I can see that at the start it said permission denied, do I need to change permissions or something?
I’ve been looking for a solution and found something where some people had similar issues, but it didn’t seem like they solved anything.


#2

Try closing all instances of Atom and rm ~/.atom/nohup.out, use sudo if you have to (make sure though that you’re using the correct $HOME :stuck_out_tongue:).


#4

Hey, so I did sudo rm ~/.atom/nohup.out so now when I open atom from the terminal I don’t get any error messages, but I still don’t get the atom window to show up. If I double click on the icon in the side menu (ubuntu 15) it just goes to my background and the brightness is lowered, meaning it hasn’t opened fully. Any other suggestions?


#5

Try closing all instances of Atom again, then mv ~/.atom ~/.atom.bak and start Atom again, if it still doesn’t work, start Atom in safe mode with atom --safe. How did you install Atom by the way?


#6

It still won’t open, even in safe mode. I installed it with sudo apt-get install atom. When I try to download the .deb from atom.io, it always tries to open it in ubuntu software centre anyways. Should I try straight from the site again?


#7

As far as I know there’s no official ppa release channel yet, so yeah, try installing the .deb from atom.io. You can run sudo dpkg -i path/to/atom-1.x.deb to install it.


#8

You are correct, there is no official PPA release channel currently.


#9

Yeah you’re right I didn’t use apt-get. I just opened it with software centre from my downloads.

sudo dpkg -i path/to/atom-1.x.deb'dpkg: error processing archive path/to/atom-1.x.deb (–install):
cannot access archive: No such file or directory
Errors were encountered while processing:
path/to/atom-1.x.deb`


#10

You should replace path/to/atom-1.x.deb with the actual path to the .deb file on your computer, I’m sorry I wasn’t clear about that.


#11

Oh haha sorry, I’m kind of new to linux and don’t want to mess anything up so I’m copying exactly what you write. I put the proper path in but it’s still not opening. I tried safe mode too and still nothing.


#12

Any other suggestions? I could probably back up all my files and re-install ubuntu. But I’ll only do that if all else fails. The things we do for Atom haha


#13

But there is an unofficial one I’m about to try. https://github.com/alanfranz/atom-text-editor-repository.

I don’t know if this is actually a PPA but it seems to accomplish the same thing`.


#14

I think I’m going to have to reinstall ubuntu. I just went into a guest session and was able to open Atom from the command line. I am also sure that I didn’t install anything since the last time I was able to open Atom.


#15

You could still try to remove ~/.config/Atom/, but I really doubt that’s going to solve anything…