Atom wipes .apmrc on launch


#1

When I launch Atom, it wipes my changes to .apmrc, I’ve tried editing it with Notepad++ and with CLI, and I have made sure that after I saved it, closing it and opening it again worked, and that my changes actually saved, and they did. Thanks for any help, I have no idea why it is doing this because I’m not even able to use apm in Atom without a proxy set, which is what I was trying to do


#2

You mentioned in chat that this happens with atom --portable, is that still the case? Or is this a more general problem?

Also, could you give the following information?

  • Which version of Atom are you using?
  • What OS and version are you running?
  • Can you reproduce the issue after completely exiting Atom and restarting using atom --safe?
  • What is the full path to the .apmrc file you’re using?

#3

Atom 1.3.2 Windows portable zip from GitHub on Windows 7 is what I am running, PC at school.

The .apmrc file at C:\Users\js*****.atom\apm is being located and read once I tried setting it to read only it now doesn’t wipe it, but I get a tunnel error (address not found), when using the following values for a proxy setting to install packages:

proxy=http://js*****:[password]@10.2.0.21:8080 http-proxy=http://js*****:[password]@10.2.0.21:8080 https-proxy=http://js*****:[password]@10.2.0.21:8080 strict-ssl=false
That IP is the address of our proxy server, which is the one we use to connect to the web with ftp://, http://, https://, etc.


#4

To my understanding, the --portable switch essentially puts the .atom folder as a peer to the directory where the Atom files are stored. So if the program files are in D:\foo\atom then the .atom directory would be D:\foo\.atom, yes? So shouldn’t your .apmrc file be in D:\foo\.atom\apm\.apmrc?


#5

I am not running it with the --portable switch, just running the exe found in the atom-windows.zip file on GitHub downloaded and extracted on a flash drive.

Also, I am running 1.4.0-beta3, I forgot that I download the top version and not the release, but that shouldn’t make much of a difference


#6

Found the solution, was using the wrong .apmrc. You must use the .apmrc in the root of your .atom folder, the one in .atom.apm will not work, as that gets reset to the default every time apm is launched.


#7

Closing by request.


#8