Atom window won't open in Ubuntu 18


#1

I have a new laptop with a fresh install of Ubuntu 18.04 (with GNOME desktop). I’ve installed Atom (first via the PPA, then via snap), but when I launch Atom, all I get is an icon on the dock and a menu item at the top of the GNOME desktop, but no actual Atom window, as shown in this screenshot:

Any ideas what might be causing this?


#2

What happens if you uninstall Atom completely and then install it from the GitHub releases page?


#3

Ok, I followed your suggestion… I uninstalled and then installed the .deb from GitHub like so:

# Install Atom
sudo dpkg -i atom-amd64.deb
# Install Atom's dependencies if they are missing
sudo apt-get -f install

But unfortunately it still does the same thing.


#4

Okay. Open a terminal window and type atom -f. This should cause Atom to report to the console about what it’s doing.


#5

Unfortunately, nothing is being printed to the console:

image


#6

What happens if you try atom --safe? What happens if you rename the ~/.atom/ folder and then try to open Atom?


#7

Sadly, they both result in the same behavior as the first post.


#8

Hmmm I’ve installed Atom on Ubuntu 18.04 with the official .deb and the official package repository with no problem, not sure what the issue could be (unless the PPA/snap installs/uninstall might be related?).

Does running just atom -v return anything?


#9

Running atom -v returns the following:

Atom    : 1.27.2
Electron: 1.7.15
Chrome  : 58.0.3029.110
Node    : 7.9.0

My laptop is a new Dell Precision 5520 (running Ubuntu 18.04). It has an NVIDIA Quadro M1200 GPU in addition to the integrated graphics chip. Is it possible that the graphics configuration on my machine is messed up somehow? I’m not a Linux superuser by any means. Here is some of the command line graphics info I’ve come up with:

$ sudo lshw -class display
  *-display                 
       description: 3D controller
       product: GM107GLM [Quadro M1200 Mobile]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a2
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:143 memory:ec000000-ecffffff memory:c0000000-cfffffff memory:d0000000-d1ffffff ioport:e000(size=128) memory:ed000000-ed07ffff
  *-display
       description: VGA compatible controller
       product: Intel Corporation
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 04
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:135 memory:eb000000-ebffffff memory:80000000-8fffffff ioport:f000(size=64) memory:c0000-dffff
$ sudo lspci -v -s 00:02.0
00:02.0 VGA compatible controller: Intel Corporation Device 591b (rev 04) (prog-if 00 [VGA controller])
	Subsystem: Dell Device 07bf
	Flags: bus master, fast devsel, latency 0, IRQ 135
	Memory at eb000000 (64-bit, non-prefetchable) [size=16M]
	Memory at 80000000 (64-bit, prefetchable) [size=256M]
	I/O ports at f000 [size=64]
	[virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
	Capabilities: [40] Vendor Specific Information: Len=0c <?>
	Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
	Capabilities: [ac] MSI: Enable+ Count=1/1 Maskable- 64bit-
	Capabilities: [d0] Power Management version 2
	Capabilities: [100] Process Address Space ID (PASID)
	Capabilities: [200] Address Translation Service (ATS)
	Capabilities: [300] Page Request Interface (PRI)
	Kernel driver in use: i915
	Kernel modules: i915
$ sudo lspci -v -s 01:00.0
01:00.0 3D controller: NVIDIA Corporation GM107GLM [Quadro M1200 Mobile] (rev a2)
	Subsystem: Dell GM107GLM [Quadro M1200 Mobile]
	Flags: bus master, fast devsel, latency 0, IRQ 143
	Memory at ec000000 (32-bit, non-prefetchable) [size=16M]
	Memory at c0000000 (64-bit, prefetchable) [size=256M]
	Memory at d0000000 (64-bit, prefetchable) [size=32M]
	I/O ports at e000 [size=128]
	[virtual] Expansion ROM at ed000000 [disabled] [size=512K]
	Capabilities: [60] Power Management version 3
	Capabilities: [68] MSI: Enable+ Count=1/1 Maskable- 64bit+
	Capabilities: [78] Express Endpoint, MSI 00
	Capabilities: [100] Virtual Channel
	Capabilities: [250] Latency Tolerance Reporting
	Capabilities: [258] L1 PM Substates
	Capabilities: [128] Power Budgeting <?>
	Capabilities: [600] Vendor Specific Information: ID=0001 Rev=1 Len=024 <?>
	Capabilities: [900] #19
	Kernel driver in use: nvidia
	Kernel modules: nvidiafb, nouveau, nvidia_drm, nvidia
$ prime-select query
nvidia

#10

Not sure if it’s graphics related if the window isn’t showing at all (I’ve mainly seen people report glitches or a window with a completely white screen) but you can try this if you’d like:

https://flight-manual.atom.io/hacking-atom/sections/debugging/#check-if-your-gpu-is-causing-the-problem

From your screenshot I see the Atom icon showing up on on the dock bar - if you right click it, do you get a menu with “All Windows”, “New Window”, etc.?


#11

Ok, I just tried the GPU troubleshooting tips from that link and they didn’t work, unfortunately.

When I right click on the Atom icon in the dock I do get the menu with “All Windows”, “New Windw”, etc.

The funny thing is, if you look at the thumbnail under “All Windows” it looks sort of like there’s a window open that is only a few pixels wide.


#12

Ohhhh so it seems like the window is there, it’s just super narrow and off-screen?

You could also give these steps a try to manually get out of this situation (assuming that the window is in fact there and just super narrow and off-screen):

Or if that doesn’t work, you could try clearing saved state (though note that you’ll lose any unsaved data):

https://flight-manual.atom.io/hacking-atom/sections/debugging/#clearing-saved-state


#13

Yes, the issue described in that GitHub link is exactly what I was experiencing! It works now! Thank you so much!!!


#14

Same thanks!!!