Atom will only work if I open with "sudo atom"


#1

Hi there - I’ve just installed atom on my 32 bit Ubuntu VM using the package from the webupd8team/atom PPA (I tried building from scratch but kept getting syntax errors when trying to run it).

The problem is that when I run atom as a regular user it opens but not in a functional state - it displays what looks like developer tools and the editor space is blank and I cannot open any files for editing - however if I open with “sudo atom” it opens normally and is functional.

Can anyone enlighten me as to why this might be the case? I’d prefer to run it as my regular user.


#2

I have the same issue, it seems Atom is set up to read/write to some file that needs special access. Looks like they tried to fix this; https://github.com/atom/atom/issues/3056, but idk.

To anyone encountering this frustration; I’ve made a less secure, not ideal workaround by setting up Atom to be granted sudo-permissions without needing a password and running “sudo Atom” as default text editor.

Please let me know if there is a better way :slight_smile: