Atom Very very very slow on editng with braces


#1

Hi,
issue:
I’ve noticed in the recent release of Atom (I’m on Linux with version 1.14.2, editing JavaScript source code), that out of the blue, it can sometimes take 10 seconds or more to handle certain situations:

What I’ve identified so far is:

On typing /* it goes into la la land for a looooong time.
Also after type (

It doesn’t happen every time- but in any one editing session it will happen many times, but not always consistently.

Workarounds attempted:
Uninstalled Atom completely and removed the .atom sub-directory.

issue still persists with no added packages.

Generally, I find Atom very fast and no issues, I’ve been using it very happily for a few years now. This issue only showed up in the most recent releases, after an auto-update.

Thanks for creating a great product, I like the idea of electron as the backend for a desktop app.

if I need to change settings somewhere, or disable a plugin to resolve this, open to suggestions. I can’t see anything that would cause this problem from my standard install.
Thanks,
Anthony


#2

Atom doesn’t auto-update on Linux. Are you using a version of Atom that you installed from somewhere other than the Atom website? If so, I would recommend uninstalling the version you have, installing the version from the Atom website and see if the problem persists.


#3

Hi thanks for the prompt reply. I’ve added a PPA to update, hence the problem! :stuck_out_tongue: What version do you suggest I use to avoid this problem?
Regards,
Anthony


#4

Hi @leedohm,
I’ve downloaded the latest 1.15-beta3 and it seems to fix the problem.
Thanks again,
Anthony


#5

I’m glad to hear that things are working for you now :+1: