\atom\Update.exe is not a valid Win32 application


#1

I have had this problem twice now where, out of the blue, my install of Atom just kind of disappears. Last time I encountered this issue, reinstalling just gives the same problem and in order for it to work I had to manually delete the registry files and appdata files in order for Atom to reinstall again properly. This was about a week or so ago and it just happened again. As soon as I launch the application I get the error. I suspect it has to do with Atoms updates messing with things, but I’m not sure why reinstalling wouldn’t fix the problem and it’s rather annoying to lose my settings and extensions every time this happens ):


#2

How do you install Atom? Uninstalling and reinstalling Atom doesn’t normally clear your settings or delete the packages you have installed.


#3

At first I tried uninstalling using the windows tool, then just reinstalling from the website, and it immediately gave me the error again upon launch. The only way I was able to get it working again was by renaming the “atom” folder in appdata, clearing the registry of Atom based entries and then reinstalling. Which worked until now, but did clear all my stuff since it was using an entirely new folder.


#4

What error did it give you?


#5

\atom\Update.exe is not a valid Win32 application just like the title says.


#6

It sounds like the icon you’re using to launch the application is pointing to something corrupt. I would try uninstalling, using the tool. Deleting the icon you’re using and then reinstalling again.