Atom treats all my files as unstaged changes in git repository


#1

Not much to say more other than what topic says. I happens only on one computer - just after installation if I open or save any file opened in Atom it shows 87k + unstaged changes which makes atom freeze every 3 seconds. After I urn off the github package it stops. See how it looks like on the screenshot below. Any ideas what might be the reason?


#2

Nevermind I fugured the reason, my home folder was a git repository. How Can I delete this topic?


#3

You can’t. And you shouldn’t, since this question has come up multiple times and someone else might find it and be helped by the solution.


#4

Soooo, how did you fix it the issue and how did my home folder become a repository?


#5

Fixing it is as simple as deleting the .git folder.

That’s something only you can answer. What’s the date on the .git folder?


#6

Got it. You have to go into the settings and specify the project home folder. The package generator creates one by default if not already specified. I changed it and restarted Atom. Working fine and only the files in the project folder now appear in the Unstaged Changes tab.


#7

Ok, I have not done that. Thanks.