Atom transparent background no longer works since 1.19


#1

I’m using the trick introduced on transcranial/atom-transparency, to achieve transparent window on Arch Linux.

I wrote an arch package for the patched atom source. It just sets the transparent:true and frame:false on /src/main-process/atom-window.coffee, and add --disable-gpu --enable-transparent-visuals as start up option.

It works on atom 1.17.x and 1.18.x , but not work on 1.19.

On 1.17 and 1.18, the Atom window background becomes transparent, and the text is opaque. With compositor’s blurring, Atom works like a charm:

On 1.19, using same trick, the background keeps being black, and there’s smearing effect on text during scrolling:

I’m not sure if it is related to electron, from atom 1.18 to 1.19, electron upgraded from 1.3.15 to 1.6.9. And it is tough for me to dive into electron’s change.

Any idea here?

If any information is needed, I’d provide as I can.


#2

A transparent background was not something we ever supported. The reason for the change is probably because of the editor rendering changes in v1.19.


#3

Thanks for the response.

I understand this is not an officially supported feature. Thus I did not put this on GitHub issues, and just wanted a place to discuss this case and find a possiple way to solve it.


#4

First thing I would probably check is to see if the BrowserWindow options have changed between 1.3 -> 1.6, and then also check the Chrome flags for changes.

(Note: use https://electron.atom.io/docs/versions/ to access older versions of Electron docs)