Atom to Github : Unable to push: remote repository not found


#1

I’m suddenly unable to push to my github repo. This was working find until recently. I can push from my Github Client Application just fine.

I’m using Atom 1.31.2 on MacOS 10.13.6.


#2

Are you having trouble with just a particular repository or any of your repositories?

Do you see any additional errors in devtools console?


#3

Thanks for your response @rsese

Every/All Repos, even ones that previously worked.

Normal Error:

Unable to push

remote: Repository not found.

fatal: repository 'https://github.com/xxx/xxx.git/' not found

Dev Tools Error:

Uncaught (in promise) TypeError: Cannot read property 'mentionableUsers' of null
at UserStore.loadMentionableUsers (/Applications/Atom.app/Contents/Resources/app/node_modules/github/lib/models/user-store.js:191:57)
at <anonymous>

#4

Are these user repositories or organization repositories?

Also, you mentioned:

I can push from my Github Client Application just fine.

Just to clarify, you’re working with these repositories over HTTPS in GitHub Desktop as well?


#5

@rsese

These are my private user repos.

HTTPS using Github Desktop works, pushing git commands from Terminal works, pushing from Atom also used to work.

Thank you,


#6

hmm that’s odd, Atom should be using the same credential helper you have configured on your computer so I’d expect if it works in Terminal, it would work in Atom.

I guess it’s maybe possible that Atom is using incorrect cached credentials - can you check Keychain Access and search for atom-github and let me know if you have a atom-github-git entry?


#7

Thanks for getting back to me @rsese

I have only one entry for atom-github , there are no results for atom-github-git


#8

No relation to OP and I have been seeing this exact issue lately (probably for the last month or so). IIRC it is somewhat intermittent, though it typically fails. Command line push always works.


#9

@cappslock

  1. Are your dev tools errors and keychain credentials the same as mine?
  2. When you say it’s intermittent, does that mean it stops working but then begins working again?
  3. Was there any action you took before it began working again?

#10

I am also getting this issue… git is working from terminal. I am using the latest Atom version on macOS 10.13.4.


#11

I’m having the same issue, latest Atom on OSX 10.10.5, it was working a couple of weeks ago, SourceTree is pushing just fine but Atom won’t find the repo.


#12

Same issue here, pushing with the terminal works fine but it doesn’t using Atom.


#13

@langfordmorrow - one thing we can try is to remove your github.com credentials so you’ll be prompted for credentials again (I’m assuming you haven’t been prompted for credentials when pushing with Atom). It doesn’t really explain why things suddenly stopped working for you, but we could at least narrow things down to saved credentials if this works.

On macOS you can removed saved credentials for github.com as documented here:

https://help.github.com/articles/updating-credentials-from-the-osx-keychain/

Then restart Atom and try to push and you should be prompted for your credentials (if you have 2FA enabled, use a personal access instead of your password).


#14

@rsese

This resolved the issue for me. I deleted all my credentials from Keychain Access (web and application). Then I loaded Atom Git / Github and generated a new access token.

I can now push and pull with no errors.

Thank you for your help


#15

Awesome! Still confused why it randomly stopped working and why it worked in Terminal but I’m glad that helped :+1:

For folks having the same/similar issue where you can’t push over HTTPS with the GitHub package, you might want to try clearing credentials as well and re-enter your credentials (with the same note that if you have 2FA enabled, you need to use a personal access token for the password).