Atom throwing several "Failed to load the xyz package" errors


#1

Hi guys,

First of all, I’d like to say that I’m new to github and want to apologize before if I do/post/whatever in a wrong way here…

Today I launched my atom.exe like I always do but was prompted with several errors like in the title:

Failed to load the emmet package...

See below for an example:

I assume it’s because of the new update to atom itself? Any ideas how to fix this?
I already tried to uninstall and reinstall all the packages - no help.

Best regards,
daftpanda


#2

Sorry for double, but I completely removed atom from my system (win7 ultimate 64bit), reinstalled it
and installed the packages again - but the same errors occurred :frowning:

It seems its a broad problem with the latest atom release…


#3

Try this:

  1. Completely close all instances of Atom
  2. Delete the directory ~/.atom/compile-cache
  3. Start Atom again

#4

Hmmm, interesting… I also recently got a report for one of my packages that a node module couldn’t be found, even though it is installed:

@leedohm Thanks for the suggestion. I’ll forward it in the issue.


#5

@leedohm thanks for the suggestion - but this didn’t work for me…
Same errors again…


#6

Funny - I can’t even use RETURN in my atom (editor) :frowning:


#7

This is often an issue caused by Emmet. Can you try disabling it?


#8

Yep - disabled it and return works again :slight_smile: Thank you leedohm :+1:

But yah, let’s go back to topic (my fault by posting the return-issue though^^)

Any idea how to solve the Package-Errors? I still can’t use nearly 100% my packages installed…


#9

Other than the compile cache, I don’t have any ideas right now. I’ll keep thinking on it though.


Atom-runner package error
#10

Thank you for your efforts =)

I’ve created an issue on github:

(just for the record here)


#11

Hey everyone,

For those not following the issue, I wanted to re-post the following possible resolution. We think this may have been caused by a temporary problem with the npm servers last week and need confirmation. From @kevinsawicki’s comment on the issue:

Can people try removing the following directories, reinstalling the packages that are showing errors, and see if they still see this issue?

  • ~/.atom/.apm
  • ~/.atom/.npm
  • ~/.atom/.node-gyp

These are just cache directories used to store modules and libraries, not actual packages.

@nathansobo pointed out there was a recent npm server issue causing empty tarballs.

From http://status.npmjs.org:

Empty tarballs responses
Resolved - Cache invalidation is complete.
Sep 16, 16:29 UTC
Monitoring - Cache invalidation is ongoing and should be complete within 15 minutes.
Sep 16, 15:55 UTC
Identified - A bug in code we rolled out to our canary server at 10:52 UTC today, and which our automated checks haven’t caught caused us to return empty tarball responses to some of our users. We rolled the deployment back at 14:29 UTC and are working on invalidating caches affected by this outage.
Sep 16, 15:25 UTC


#13
  1. uninstall Atom
  2. cd ~
  3. rm -rf .atom/
  4. Re-install atom
    This worked for me.

#14

This worked for me too. Cheers :slight_smile: