Atom terminal


Hi,everyone!Recently l intalled package called “python-run-terminalnx”.I had it before i installed atom again and it worked,but when i click F5(you need to click f5 to run terminalnx) this message pops up on the screen:


Is there a specific reason why you are using python-run-terminalnx? It hasn’t been updated in some time and looking at the package code I’m not sure it’s worth debugging it and potentially having to patch it if this turns out to be a bug. If you’re just looking to run code in a cmd window, you can do that with process-palette. Just configure a new command like this:

(Edit: The first version of this post had the wrong syntax for the Windows CLI switch. I’ve updated it to the correct syntax, so that newcomers don’t have to go searching to find the correct answer.)

Then scroll down and tell it to output to nothing. This will prevent the package from creating a blank panel.

How to Run python code in Atom?

Thanks for responding me DamnedScholar!Yes, l use “python-run-terminalnx” because it runs a program in cmd window.lts like running a program in qbasic.l will try “process-palette”

Thank you


Hi,everyone!l have installed process-palette in my atom.But there is a problem.When l start typing in cmd nothing appears.Here is photo: (l am typing some words on my keyboard but nothing happens,nothing appears)


Mind showing me a screenshot of your command configuration?


D’oh! I just realized that I made a bad mistake considering that I use Windows. In the configuration I posted, I had \k as the switch, but the syntax is /k. This is correct:


Hi DamnedScholar!l tried it but l have the same problem.Here is screenshot:


This is what happens when I run it.

Did you put a new line before {fileAbsPath}? You can’t have a newline character in the middle of a command string. The command on my screen just wraps onto the next line because my window is smaller.


Hi DamnedScholar!Thank you for support!


Did it work?


Yes, thank you for support!


No problem. :slight_smile: