Atom SUPER Laggy when multi-monitor ** SOLVED **

Using Linux Mint.

Have a quad AMD with 16gb ram.

Now, in a nutshell, I have used ATOM for quite a while, it is one of the best I have found.

A while back, I stopped using it as it went laggy. When I used multiple monitors.

If I have 1 monitor, sometimes 2 max, ATOM is fast and reliable.

Now, again, I require 4 monitors on my pc so as I can program, multitask 2 browsers and have the database on another.

ATOM, went completely laggy again.

So I am using another software that I really dislike.

Does anyone have any clues, please?
Why does ATOM go so laggy it is unusable whenever I have multiple monitors?

(ATOM is being run on the MAIN SCREEN).

No other software I have come across has this problem.

Thanks in advance and for your time.

I question the need for four physical monitors (unless you are an fx trader or advanced gamer).

What if you use just one monitor, with docky installed and enable in docky the workspace switcher? Then you can have instances of Atom, browser and database view in different virtual workspaces. Works well in my Ubuntu.

Because it is quick and easy.

Just move mouse from one screen to another.
Also easier to see what is happening with changes and faster.

Thanks for the reply.

Here is another idea to get to the root cause …

  • Install stacer.

  • While running stacer select processes and filter “atom”.

  • Attached is what I see in Ubuntu 16.04.

  • Now try auditing running Atom processes while you switch your extra monitors on and off to test “lag”.
1 Like

Hi d_I

Thank you for your reply.

I removed the second graphics card (Like 100% taking out the extra monitors, as you suggested).
Of which, atom did no have any issues. Doing this also made me notice the MAIN monitor, previously when the extra graphics card was in the pc, was, in fact, running off the extra graphics card.

So, I plugged the second graphics card back in.
Put some adapters on various monitors, so I could change the configuration that the main monitor is NOT on the extra graphics card.
BiNgO, all working 100%.

Therefore the conclusion being, that for some reason, ATOM hates running on the second, extra graphics card(s). Seems atom has to be run on the primary pc graphics card.
Else it will lag so bad, you can make a coffee between page changes via the atom page tabs.

So, I would really like to thank you ever so much for the suggestion you gave with regards to the monitors.
After a lot of messing about and getting in the attic to find adapters, it is all now working, with ATOM ONLY ON THE PRIMARY CARD.
I have no idea why atom does this, no other software does this. Strange. Yet, it is what it is.
I am just so happy and grateful I have ATOM back, I just can not get along with others.
I have been using ATOM since it pretty much started and nothing I have found really compares to what it does and what I require.

So, thank you ever so much, more than words can say or mean, for your help and time.
Of which helped to SOLVED this situation.

Best Regards.

1 Like

Oh, this is only the case with regards LINUX.
It is ok on Windows. Which is a shame, I have windows.
As had the same issue on another LINUX setup a few years back.
Yet this time I have managed to sort it out and know what the issue being with your very kind time and help.

Thanks again.

have windows == hate windows

Good to have this solved.
One theory I read is that this may have been a Chrome browser issue rather than Atom.

1 Like

Hi d_I

Thanks again, I am running Firefox and only really ever use Firefox.

Also, no settings have been changed on Atom since it was installed.
I like Atom just the way it is. So have never really bothered going into the settings/prefs/etc.

Been using Atom for a fair few years now, love it just the way it is and comes as default.

I always have multiple Firefox windows open when programming.
I do right now and with the new setup of the MAIN being on the pc motherboard ‘integrated’ graphics card, Atom is now working perfectly. No matter how many Programs, Browser Windows / Tabs, etc I have open.

So it definitely seems to be that Atom doesn’t like working on additional graphics cards (On Linux Only, of which being MINT Linux, in both cases. Not sure about other Distro’s).

Yet, the main thing being, with your help, time and advice, I have ATOM back :smile:
I tried 3 other editors and none compare to Atom.

So, thank you ever so much again. It is very highly appreciated.
(I am using Atom right now again, :slight_smile: ).

(Atom also runs on any of the 4 monitors without any problems at all, when MAIN is integrated graphics card, not extra graphics card(s)).

Thanks again.