Atom suddenly looks like I pressed f12 in my browser?


#1

This is what it looks like: http://prntscr.com/9md7kj
This is what it should look like: http://img.xero.nu/thumb/atom.png

I tried reinstalling it but it still looks like this. Does anyone know how I can revert this as it’s very annoying.


#2

Try this:

  1. Close all instances of Atom
  2. Delete the ~/.atom/storage directory
  3. Delete the ~/.atom/blob-store directory
  4. Launch Atom again

In the future, please give the following information when reporting a problem. It helps us figure things out faster and lets us customize the answer to your platform.

  • Which version of Atom are you using?
  • What OS and version are you running?
  • Do you have Emmet installed?
  • Can you reproduce the issue after completely exiting Atom and restarting using atom --safe?

#3

if @leedohm instruction doesnt work, there’s an error (red circle with x). Maybe knowing it can improve the situation.


#4

Thank you, this solution worked perfectly! I can get back to work now. I was using Windows 7 sp1, Atom 1.4.0-beta 3, and Atom 1.3.2 for Windows. Emmet was installed. I hope this information helps others. Finding the files mentioned above may require a search of the C drive for “.atom” as they seem to be hidden from the directory tree.

Cheers,

Jay


#5

I use windows 10. The program worked fine a few days ago but suddenly it turned like this and I can’t find out how to revert it. I clicked the red circle (like you said @jeancroy), it gave me an error message in a directory I’m unable to reach?! This is what it says:

SyntaxError: Unexpected token 
at Object.parse (native)
    at FileSystemBlobStore.load (C:\Users\Eigenaar\AppData\Local\atom\app-1.3.2\resources\app.asar\src\file-system-blob-store.js:36:31)
    at Function.load (C:\Users\Eigenaar\AppData\Local\atom\app-1.3.2\resources\app.asar\src\file-system-blob-store.js:10:14)
    at window.onload (file:///C:/Users/Eigenaar/AppData/Local/atom/app-1.3.2/resources/app.asar/static/index.js:18:39)

And when I attempt to go to the directory \app-1.3.2\resources\app.asar\src\file-system-blob-store.js:36:31) I don’t get further than \resources because there exists no \app.asar, only \app.asar.unpacked in which there is no \src directory.

Also @leedohm I can’t find the directories you asked me for.

I’ll check if it works to install Emmet. Brb

EDIT: Installing Emmet also doesn’t work. There’s no Install section in my settings.


#6

lol that question is not to push you to install Emmet, it is juste that while a usefull plugin it cause all kind of trouble.

So the error says there’s something about blob store.
Do you have a C:\Users\Eigenaar\.atom\blob-store folder you can clear ?
also \storage in the same .atom folder ?


#7

On Windows, the more correct notation is $HOME\.atom\storage and $HOME\.atom\blob-store. (This is why I ask the question of which platform people are on :grinning:)


#8

@leedohm tried to copy/paste your path with $Home variable. That leeds to nowhere.

However this works:
%HOMEPATH%\.atom\storage


#9

@leedohm I managed to find the directory and it worked! When I opened the atom folder in app data it wasn’t there, but when I opened the users directory I found another .atom directory and there I found the storage and blob-store. I deleted them and now it worked. Thank you!