Atom stuck in half screen


I may have just done something dumb, but I have tried messing with panes and some other setting but have been unable to get my code to return to occupying the whole page. I have also tried restarting the editor… Any ideas?


The easiest way to fix this is to:

  1. Save all open files
  2. Close all copies of Atom
  3. Launch Atom again with atom --clear-window-state


Thanks man, that solved the problem


There’s a FAQ for this now:


NO GO! atom --clear-window-state

This did not work on a windows 10 computer. Every time Atom opens it has the welcome panels. I close those and only half of the screen is available to work with. Clear window state did not work as stated above. Did I mention that it is very slow to open up as well.

Any other suggestions before I send this software to the garbage pail.



What happens when you tell Atom to not show the welcome screen? You can even go into Settings -> Packages and disable the welcome package entirely.


Yes, I tried turning off the welcome screen. It didn’t help. Rebooted, that didn’t help. Checked to make sure I was on latest version. I am.

In fact, the atom --clear-window-state made things worse. Every time I start the app it goes into full-screen mode and I can no longer resize it. Even though the app is in full-screen I still only get half the panel to work with.

Anyway, I uninstalled it and installed Visual Studio Code instead. Has a lot of add-ins available and works well. Too bad, Atom looked promising.


I use Atom on Windows 10 every day and I’ve never seen anything like what you’ve experienced. If you’re interested in sharing your experiences, perhaps we could discover why the program seems to work differently for you than it does for me. Atom has always just worked for me except for one time when my state data got corrupted. Through this forum, I talk to a lot of people who have not had experiences as smooth as mine, but usually I am able to discover enough about their situation that I can figure out or research a solution.