Atom stops highlighting syntax once it exceeds window


#1

A line of code often exceeds the width of the window, and I don’t like using wrap-text. but when the text exceeds the window border, atom stops highlighting it and the text color remains the color that the last character on screen was.

not major, but a bug that needs attention, cause it’s irritating once you spot it.


#2

You must have a loooong window.

Anyway, long story short, new parser rolling out, doesn’t have that problem. You can already use it in Settings ➔ Core ➔ Enable tree sitter

Only a handful of core packages support it right now, and it currently looks a bit plainer than the old versions, but that should get better with time.