Atom stopped running (win 8.1)


#1

Hi

Since morning, suddenly I cannot open Atom. I haven’t changed anything in Atom recently.
I couldn’t find any similar topic.

I have been using Atom for about a month (if not more) and I’m facing this problem for the first time.


#2

Have you followed the suggestions in the Debugging document? Also, could you give the following information?

  • Which version of Atom are you using?
  • Can you reproduce the issue after completely exiting Atom and restarting using atom --safe?

#3

Not really needed since he can’t open it. (grin) That’s a problem with snippet replies. (grin)


#4

Thanks for reply.

  1. I cannot open Atom at all. I checked Task manager several times. there is nothing there.
  2. My version is 1.0.4.
  3. Where should I run commands?

#5

The answer to point 3 is from your local shell, CMD if you are on windows.


#6

Then I did this:

cd C:\Users\***\AppData\Local\atom\bin
atom --safe

Then I ran atom. no change


#7

As as a side note, you should be able to run atom wthout cding to atom’s bin folder…


#8

How else?
Usually I run atom from its shortcut not command line; but nothing happen.


for running Atom, I should go to the bin folder. if not I get this error:

'atom' is not recognized as an internal or external command,
operable program or batch file.

#9

Are there any Node processes still running? I forgot how they are called. Green icon, I believe they have Javascript or I/O or Engine in their name. If there are any, kill those processes and try to start Atom in safe mode. Rebooting your machine instead might be easier if that is possible.


#10

thanks

as far as I see, there is nothing related to node in my task manager.
I have already restarted my laptop. no change. should I run it in safe mode (windows safe mode)?


#11
Bummer, it was a long shot. Experienced a left-over node process myself some time ago. I don't think Windows' safe mode will help, but if you have time to play with it, can always try. I don't know what the installer adds to the system, but just Atom should only use the following directories (unless you instructed Atom to use different ones): - `%USERPROFILE%\.atom` - `%APPDATA%\Atom` The former contains your packages and your settings (along with some temporary caches and storage), the latter is mostly for Chromium related stuff. Can you try to remove them (make a backup first) to see if Atom wants to start? That should bring your system to a 'pristine' state from Atom's point of view. If it still does not start it almost has to be some external program blocking it.

While writing the last sentence I realised something… you happen to use Atom v1.0.4. too, which had signing issues on Windows. Your Antivirus might be blocking it, try upgrading to Atom v1.0.5 first to see if that fixes the problem.


#12

can i upgrade it in this situation? I mean I cannot run atom. should I reinstall it? or there is a way to upgrade without removing my settings and packages.


i removed .atom. but it was not helpful


#13

If you use the installer I am not sure what the easiest process is as I don’t use it. The zip-version contains an Update.exe, which is no doubt included for the installer-version, but I have no idea what it does. Perhaps it will automagically update Atom?

A safer method is grabbing the installer for v1.0.5 and try to install it over your current installation. If that does not work, backup your .atom folder, remove Atom and reinstall.


#14

I downloaded the latest version (1.0.5) and installed it on the existing version (1.0.4). It works now.

But I think this issue needs a proper investigation by developer teams.

Thanks guys :blush: :hand: