Atom Specs Window won't open at all


#1

I’m currently trying to write some specs for my packages and on Win10 everything works fine and all tests are passing but on Xubuntu the Atom Specs Window won’t open at all so I can’t do any tests there.

I’ve tried to remove Atom already once completely including the ~/.atom folder to get a fresh installation but no luck. Also I don’t see any error message nor I can’t find any error log that could tell me what’s going wrong. Am I missing some piece on Linux to get it work?

Guest:
  Xubuntu 15.04 (VirtualBox VM)
  Ubuntu 3.19.0-25.26-generic 3.19.8-ckt2
  Atom 1.0.7
Host:
  Win10
  VirtualBox 4.3.30

#2

Can you run your specs with apm test?


#3

If I run apm test in my package folder I get the following errors

> apm test
[1969:0816/111456:ERROR:browser_main_loop.cc(170)] Running without the SUID sandbox! See https://code.google.com/p/chromium/wiki/LinuxSUIDSandboxDevelopment for more information on developing with the sandbox on.
Cannot find module '/home/subesokun/github/atom/src/browser/atom-application'
Error: Cannot find module '/home/subesokun/github/atom/src/browser/atom-application'
    at Function.Module._resolveFilename (module.js:328:15)
    at Function.Module._load (module.js:270:25)
    at Module.require (module.js:357:17)
    at require (module.js:376:17)
    at EventEmitter.<anonymous> (/opt/atom/resources/app.asar/src/browser/main.js:77:27)
    at emitOne (events.js:82:20)
    at EventEmitter.emit (events.js:166:7)
pci id for fd 15: 80ee:beef, driver (null)
OpenGL Warning: glFlushVertexArrayRangeNV not found in mesa table
OpenGL Warning: glVertexArrayRangeNV not found in mesa table
OpenGL Warning: glCombinerInputNV not found in mesa table
OpenGL Warning: glCombinerOutputNV not found in mesa table
OpenGL Warning: glCombinerParameterfNV not found in mesa table
OpenGL Warning: glCombinerParameterfvNV not found in mesa table
OpenGL Warning: glCombinerParameteriNV not found in mesa table
OpenGL Warning: glCombinerParameterivNV not found in mesa table
OpenGL Warning: glFinalCombinerInputNV not found in mesa table
OpenGL Warning: glGetCombinerInputParameterfvNV not found in mesa table
OpenGL Warning: glGetCombinerInputParameterivNV not found in mesa table
OpenGL Warning: glGetCombinerOutputParameterfvNV not found in mesa table
OpenGL Warning: glGetCombinerOutputParameterivNV not found in mesa table
OpenGL Warning: glGetFinalCombinerInputParameterfvNV not found in mesa table
OpenGL Warning: glGetFinalCombinerInputParameterivNV not found in mesa table
OpenGL Warning: glDeleteFencesNV not found in mesa table
OpenGL Warning: glFinishFenceNV not found in mesa table
OpenGL Warning: glGenFencesNV not found in mesa table
OpenGL Warning: glGetFenceivNV not found in mesa table
OpenGL Warning: glIsFenceNV not found in mesa table
OpenGL Warning: glSetFenceNV not found in mesa table
OpenGL Warning: glTestFenceNV not found in mesa table
libGL error: core dri or dri2 extension not found
libGL error: failed to load driver: vboxvideo
ATTENTION: default value of option force_s3tc_enable overridden by environment.
OpenGL Warning: glXChooseFBConfig returning NULL, due to attrib=0x2, next=0x20
[1988:0816/111457:ERROR:gl_surface_glx.cc(637)] glXChooseFBConfig failed.
[1988:0816/111457:ERROR:gpu_info_collector.cc(27)] gfx::GLContext::CreateOffscreenGLSurface failed
[1988:0816/111457:ERROR:gpu_info_collector.cc(89)] Could not create surface for info collection.
[1988:0816/111457:ERROR:gpu_main.cc(410)] gpu::CollectGraphicsInfo failed (fatal).
[1988:0816/111457:ERROR:sandbox_linux.cc(325)] InitializeSandbox() called with multiple threads in process gpu-process
[1988:0816/111457:ERROR:gpu_child_thread.cc(146)] Exiting GPU process due to errors during initialization

#4

Did you compile atom from source or did you use a .deb package ?
I can run specs in my VM but I installed the .deb package. Does /home/subesokun/github/atom/src/browser/atom-application even exist on your machine ?
The GL errors could also mean a problem with your VM configuration but maybe they are caused by the first error. I’ll recompile atom in my VM and see if I can reproduce this issue somehow.


#5

No I didn’t compile it on my machine, I’ve simply installed via apt-get from the webupd8team PPA. I think the GL errors can be ignored for now as I see them always as VirtualBox has some issues with hardware acceleration.Yes the folder /home/subesokun/github/atom/ isn’t existing so I wonder why apm tries to use this path.


#6

Could this be an issue of the PPA you’re using ? I use the .deb of atom.io.


#7

No luck either if I install Atom from the deb package. Inspired by this script I’ve tried the following but also without luck in the end.

apm test --path /usr/share/atom/resources/app/atom.sh 
/usr/share/atom/resources/app/atom.sh: line 87: /tmp/atom-build/Atom/atom: No such file or directory
Tests failed

But at least it seems like it did progress a bit as compared to before.


#8

atom.sh:

  SCRIPT=$(readlink -f "$0")
  USR_DIRECTORY=$(readlink -f $(dirname $SCRIPT)/..)
  ATOM_PATH="$USR_DIRECTORY/share/atom/atom"
  ATOM_HOME="${ATOM_HOME:-$HOME/.atom}"

  mkdir -p "$ATOM_HOME"

  : ${TMPDIR:=/tmp}

  [ -x "$ATOM_PATH" ] || ATOM_PATH="$TMPDIR/atom-build/Atom/atom"

atom (or here: apm) defaults to this temporary folder if $USR_DIRECTORY/share/atom/atom does not exist. I tried your command and I had this error too because --path has to point to the atom script in your $PATH.
I usually compile atom manually (because Arch Linux) so I would use apm test --path /usr/local/bin/atom (you should try /usr/bin/atom although apm probably uses that as a default anyways).
That being said I’m officially out of ideas :sweat:


#9

I’ve tried it now with --path /usr/bin/atom but as you’ve predicted it didn’t work. Anyways, thanks a lot for your help so far!


#10

I faced same issue and renaming ~/github/atom or setting ATOM_DEV_RESOURCE_PATH=null fixed this.
It is because Atom loads *.coffee and etc. files from ATOM_DEV_RESOURCE_PATH when in dev mode.

      ATOM_DEV_RESOURCE_PATH  The path from which Atom loads source code in dev mode.
                              Defaults to `~/github/atom`.