Atom Shell Version Management


#1

I wrote a little tool for myself, because I got annoyed about keeping my atom-shell version up-to-date and having to run ~/Downloads/atom-shell-v0.20.5-darwin-x64/Atom.app/Contents/MacOS/Atom app/ to execute my applications. Since other people might have the same problem, I thought I’d share it with you guys.

ASV (https://github.com/omnidan/asv) let’s you easily manage your atom-shell versions and allows you to run atom-shell with an atoms command.

It works like n (nodejs version management) and m (mongodb version management) and can be installed using npm: npm install -g asv
After installation, simply run asv latest and it’ll download the latest atom-shell version, then run atoms to run it.

Works on linux and OS X. Please let me know what you think!


#2

Hi Omnidan,

asv solves a real problem and I really would like this tool to work.

I tried to run atoms on my mac for my atom-shell application but the browser window doesn’t show up.
Same thing then I run without any parameter such as:

$ atoms
[33134:0415/081716:INFO:renderer_main.cc(212)] Renderer process started
<< NO browser window >>>

But if I explicitely use the path, instead on relying on the symbolic links that asv created, I do get thw window:

/usr/local/asv/versions/0.23.0/Atom.app/Contents/MacOS/Atom
[33144:0415/081741:INFO:renderer_main.cc(212)] Renderer process started
<< browser window shows up >>

Your asv tool solves a real problem but something isDo you think atom may have issue when launched through symbolic links?


#3

Hi pcarion,

Thanks for your support, yes, it does solve a big problem - I use it a lot personally.

Your issue kinda surprises me, I just tried a fresh install of asv (1.0.3) (maybe try updating to that if you aren’t on 1.0.3, check with asv -v) and it works fine for me. (I am on OS X Yosemite)

Please try running the following commands:
npm install -g asv
asv -v
asv latest
atoms --version
atoms

And let me know what happens/what the output of those commands is.


#4

Installing through npm works indeed!

(I previously installed your app using: $ git clone git://github.com/omnidan/asv.git && cd asv && make install)

Thank you for this great tool. Already loving it.


#5

Oh, that’s interesting. Using npm is the preferred way to install it but I’ll definitely look into the issue when installing from source.

Thanks for the feedback, always happy to see someone else than me finding my tools useful :slight_smile:

Edit: It seems like you got an old asv version when you cloned the repo, even cloning and running make install worked fine for me, the way you install it shouldn’t affect the symlink as it’s created by asv, not by the Makefile.