"atom ." shell command does not open a new Atom window


I typically use to launch atom in a directory by issuing “atom .” in my zsh shell. This is particularly useful for browsing different project side-by-side.

After updating to v0.169.0, this no longer opens a new window if an instance of Atom is already open, but rather just gives focus to the existing window. In other words, I can currently conveniently only use Atom for one project at a time.


Curiously, got it now working after the 12th try or so. Will keep an eye on this for a while.


It’s generally helpful if you include what OS and version you’re running too. (Especially for things that involve the launch process … since each platform is subtly different there.)


Oh sorry @leedohm , silly of me. Running Atom v0.169.0 on OS X 10.10.1 Yosemite, zsh 5.0.5. “atom” command symlinked as /usr/local/bin/atom -> /Applications/Atom.app/Contents/Resources/app/atom.sh.


Does this also happen when using another shell than zsh?


I’ve seen this occur. OS X 10.9.4. I also, happen to be using zsh. In particular “oh-my-zsh” (which is awesome btw).

I actually see this happening when I.

  1. atom .
  2. atom -d . <—sometimes just doesn’t open. I’ll usually quit all open ones and restart to fix this.


I had this sometimes on linux. Usually it was because atom did not quit correctly and there were still some instances running in the background. I had to kill them manually to make atom work again.


@despairblue, @DavidLGoldberg, that’s good to know, thanks for weighing in! For some reason I had never encountered this before.


Sharing in case anyone else has issue…

OSX 10.12.1 / iTerm / zsh & oh-my-zsh


  1. Try to open atom from terminal
  2. Term produces error: zsh: command not found: atom


  1. cd /usr/local/bin
  2. rm atom
  3. ln -s /Applications/Atom.app/Contents/Resources/app/atom.sh /usr/local/bin


Easiest fix

edit ~/.zshrc
uncomment #export PATH=$HOME/bin:/usr/local/bin:$PATH It should be the 2nd line.
Open atom.
Select Atom-> install shell commands

That is all there is too it.


For those who still encounter this problem.

Make sure that the symlink is properly configured.

Solution (reference from @alechp, but just a little different)

  1. cd /usr/local/bin
  2. rm atom
  3. ln -s /Applications/Atom.app/Contents/Resources/app/atom.sh /usr/local/bin/atom

This links the atom command to the shell script in your atom application.

Make sure /usr/local/bin is in your path!

Solution (reference from @th-m)

  1. edit ~/.zshrc
  2. uncomment export PATH=$HOME/bin:/usr/local/bin:$PATH

This makes sure that when you call atom in your terminal, it looks into your /usr/local/bin to find atom

I hope this summarises everything :slight_smile: Thanks to the people who posted their solution here :smiley:


$ ps aux | grep atom

Find the pid then

$ kill <pid> or $ sudo kill <pid>


Just follow this steps:

Open Atom > click on Atom tab on the top > select “Installs Shell Commands” options. Done!