Atom seems to be making changes all over my files when I save


When I start making changes in my file, it will start to add the git diff lines to where it says there are “changes” to the file, but I’ve made no changes.

I do a git diff on it, and it will say “these lines are exactly the same”.

This only happens when I actually make a change and save it, whereas if I just add the change and not save, it will add the git diff lines, but not all over the file.

Was wondering if there is a reason for this or what.


Found it, it was the Whitespace package that was causing the issue.

You can go to Preferences -> Whitespace and either uncheck both boxes or just disable it.

closed #3