Atom seems flakey, cannot start


#1

Windows 7 user.
So I installed yesterday, and all looked great.
created my own syntax theme. yeah!

Today, Atom suddenly decided to close in the middle of editing a file, and upon reopening all I got was the developer tools, no packages, and could not open any files, folders, etc, even though I could select such.

  • Sigh. Tried everything I could think of or find online. Nothing helped.
  • So I uninstalled, removed the .atom directory and the github directory from c:\users<myaccount>.-
  • Reinstalled.
  • Things seemed back to normal. No theme but could open a project, and do some editing.
    yeah!

Decided to close and reopen just to be sure.
Dang, the editor is crashing on startup. See attached snippet.

  • This message reoccurs if a reload is attempted, or if close and relaunch is done.
  • This time there was no github directory. Perhaps as I had not generated a syntax theme
  • Noticed that the .atom/packages has only the README.md file.
  • Cannot find a log or error dump to inspect. Checked registry and C:\Users<myaccount>\AppData\Local\atom, no mention of a log file
  • Nothing in the Windows Event viewer.

Any suggestions before I just go back to Eclipse.


#2

Did another uninstall / reinstall.

  • Was able to open the project folder, edit a file.
  • Was able to close and restart Atom.

Then tried to generate a theme, which was successful again.

  • Applied theme, and reloaded Atom (Ctrl-Alt-R), and saw it applied.
  • Was able to edit and save a file.
  • Exited Atom, and got same error when launching.
  • Using file explorer, opened C:\Users<myaccount>.atom\packages\my-syntax and was able to open that in Atom. Surprised that this pseudo-directory could be opened, but it worked.
  • Made some changes to base.css to change tab background, saved, and Ctrl-Alt-R showed changes applied.
  • Was able to Open File, edit and save the file.
  • But Open Folder or Add Project Folder after selection will cause the prior Editor crash.
  • The Theme editor window remains active and can do some actions such as examine and edit Settings.
  • The Selection, Find, and Packages menus are populated.

#3

I’m not sure what the issue is. You seem to be saying that it is crashing on startup? Have you followed the suggestions in the Debugging document? Also, could you give the following information?

  • Which version of Atom are you using?
  • Can you reproduce the issue after completely exiting Atom and restarting using atom --safe?
  • Can you specify how you are launching Atom? i.e. what command or other action you’re using?
  • Can you specify where you are launching Atom? i.e. in what directory, what files are you attempting to open, etc?
  • Can you give any other relevant details to the actual problem (if I am indeed correct in understanding what the problem was)?

#4

Thank you for your response…

  • Debugging document steps

  • C:\Users\choffman>atom.cmd --version
    [9908:1030/004313:INFO:CONSOLE(0)] 1.1.0

  • C:\Users\choffman\temp>dir C:\Users\choffman\AppData\Local\atom
    Volume in drive C is Windows7_OS
    Volume Serial Number is A870-9C6C

    Directory of C:\Users\choffman\AppData\Local\atom

    10/29/2015 07:12 PM .
    10/29/2015 07:12 PM …
    10/29/2015 07:10 PM app-1.0.19
    10/29/2015 07:12 PM app-1.1.0
    10/29/2015 07:12 PM 186,361 app.ico
    10/29/2015 07:10 PM bin
    10/29/2015 07:12 PM packages
    10/30/2015 01:18 AM 470,722 SquirrelSetup.log
    10/29/2015 11:24 AM 1,517,832 Update.exe
    3 File(s) 2,174,915 bytes
    6 Dir(s) 80,488,361,984 bytes free

  • C:\Users\choffman\temp>apm links
    C:\Users\choffman.atom\dev\packages (0)
    └── (no links)
    C:\Users\choffman.atom\packages (0)
    └── (no links)
    C:\Users\choffman\temp>

  • I have not modified Atom’s Init script or Stylesheet

  • When I launched Atom, and opened the Developer Tools, then attempted to Load Folder in my real directory, no logging was displayed as error window displayed, or after error window was dismissed via “close window”.

  • C:\Users\choffman> atom.cmd --safe
    The problem still occurs with the same popup message.
    That is, Atom is launched, but when Load Folder or Add Project Folder is selected from menu, the error occurs.


#5
  • I have launched it from the default icon, whose properties were setup by the default install values.
    TARGET: C:\Users\choffman\AppData\Local\atom\Update.exe --processStart atom.exe
    START IN: C:\Users\choffman\AppData\Local\atom\app-1.1.0
  • I have launched it from the command prompt.
    C:\Users\choffman>atom.cmd --safe
    where the path included
    C:\Users\choffman\AppData\Local\atom\bin
  • When I open in a non-git controlled folder, with several meaningless small files, it opens just fine, loads my syntax definitions, and life is good.
  • When I open my real git controller folder, then the error occurs.
    Sorry, I cannot give you the name, company proprietary details, however it is simply a git clone, and is the same directory that I was able to connect to when the welcome screen is shown on starting Atom for the first time after a new install.
  • The same error occurs if I attempt to open any sub-directory under root directory for my project.
  • Opening any random directory seems to work, for example C:\Users\choffman\Downloads
  • Looking in my project root directory I don’t see any unexpected files.

#6

So the editor only crashes when opening Atom inside your Git project?


#7

I have the same issue with my git folder. I’m using Windows 10.

Tried a clean installation without any packages, but no luck so far…


#8

Atom is remembering where I last opened, As I had successfully entered the PackageGenerator:Generate Theme Syntax for my choffman-syntax theme, it now opens that. So the failure now is shown when Open Folder or Add Project Folder is selected. I suspect this is the same action that was causing the failure previously when my project was the last window opened, and the launch was attempting to load my project.

It doesn’t seem to matter where I open Atom. From the Start Menu icon, from the command line in any directory. What seems to matter is opening a folder either by itself or as a project folder.

Unfortunately I can not upload the style changes, but the generator seemed to start with the built in style I was using at the time which I believe was “Base 16 Tomorrow Dark”,

colors.less: I added

brown: rgb(81,65,28);
@light-brown: lighten(@brown, 25%);
@very-light-brown: lighten(@brown, 50%);
@yellow: #cccc66;
@true-green: #080;
@white: #ddd; // not quiet pure.
@bright-white: #FFF;
@black: #000;

syntax-variables.less, I modified

@syntax-background-color: @black; 
@syntax-invisible-character-color: @brown;
@syntax-gutter-background-color: @dark-gray;
@syntax-gutter-background-color-selected: @dark-gray;

base.less, I added

.tab-bar .tab,
.tab-bar .tab .title,
.tab-bar .tab .close-icon{
    background-color: @dark-gray;
    background-color: #300;
}
.tab-bar .tab,
.tab-bar .tab .title {
    color: @very-light-brown;
}
.tab-bar .tab.active .title{
    color: @white;
}

ul.tab-bar li.tab.sortable,
ul.tab-bar li.tab.sortable div.title,
ul.tab-bar li.tab.sortable div.close-icon{
  background-color: @brown;
}

ul.tab-bar li.tab.sortable.active ,
ul.tab-bar li.tab.sortable.active div.title ,
ul.tab-bar li.tab.sortable.active div.close-icon {
    background-color: #040;
}

ul.tab-bar li.tab.sortable div.close-icon {
  color: @light-gray;
}
ul.tab-bar li.tab.sortable.active div.close-icon {
  color: @white;
}
ul.tab-bar li.tab.sortable div.close-icon:hover ,
ul.tab-bar li.tab.sortable.active div.close-icon:hover {
  color: @bright-white;
}

#9

@leedohm, When I get a chance today, I will do a fresh uninstall/reinstall, and generate a theme with no changes, and see what happens, and then a gradual increase in changes.
Does this approach make any sense to you?


#10

To be honest, I’m having a hard time figuring out what the real issue is. Each post of yours is bombarding me with more and more information. Rather than narrowing things down, each post adds more information and I can’t tell if that additional information is relevant or not.

What I need in order to help you better is:

  1. What is “the error”?
  2. What are the simplest list of steps that will reproduce the issue?

Check this pull request with additions to the documentation on how to write good bug reports for some suggestions.


#11

Looking over issues today I came upon this. The issues people seem to be having appear similar to what you’re running into:

It appears that some state in the Git repository is crashing libgit2, the library that Atom uses to access the repo information, which then crashes Atom.


#12

That looks suspiciously similar.
As of today, no access to the git project, but also no problems in some dummy non-git project.

I did the following:

  • Uninstalled Atom via Control Panel / Programs / Programs and Features
  • Manually removed C:\Users\choffman.atom
  • Manually removed C:\Users\choffman\github
  • Manually removed C:\Users\choffman\AppData\Local\Atom
  • Using Registry Editor, ensured no entries contained the whole word 'Atom" or “atom”
  • Installed Atom using only default settings
  • At end of installation, Atom application launches
  • Left pane has inactive tab “untitled”, and active tab “Welcome”
  • Right pane has active tab “Welcome Guide”
  • Opened a project via menu File / Add Project Folder, then selected a directory in my local git repository clone.
  • Tree view is populated with folder contents.
  • Can open, edit, and save files.
  • File / Exit, to close Atom
  • Restart Atom from Start memu,
    Target: C:\Users\choffman\AppData\Local\atom\Update.exe --processStart atom.exe
    Start In: C:\Users\choffman\AppData\Local\atom\app-1.1.0

Will attach screen captures as the system allows.


#13


#14


#15


#16