Atom seem to ignore keymap.cson (I can't override keybindings)


#1

Hello,

I looked over a lot of threads that discuss this issue, but I still can’t set my keybindings. I tried to set some shortcuts for Emmet, but I’m not able to set ctrl-e, ctrl-alt-e or ctrl-alt-enter (for emmet expand abbreviation). I still get search bar altough when I run Settings->Keybindings, no other keybindig is set (for expample for ctrl-alt-enter), only the emmet one in my .cson. I tried setting !unset first and then defining the keybinding, but it didn’t work either.

I’m pretty desperate about this, because this is the only thing that puts me away from using Atom.
Important note: I’m on Linux (Fedora).

Any advice greatly appreciated.


#2

Have you tried enabling the key-binding-resolver panel to assert which commands is triggered?
This looks like a scoping problem for me.


#3

For ctrl-alt-enter it shows me that it triggers (resolves to) emmet expand abbreviation, but it doesn’t trigger the command - it shows me a “find” box instead.


#4

It looks like yet one more issue needs to be posted to the emmet package.


#5

If you can post a screenshot of what the Keybinding Resolver looks like when you try to execute one of your custom keybindings, that should be more helpful.

Also, !unset is only if you want a key to do nothing. If you want a key to do something different than what it is doing … then just set it to that other thing.


#6

Thanks your replies.

Yes, I know that !unset unsets the thing, but when I do debugging of this sort I try to be paranoid (and do double (or triple) checks).

I’m attaching the screenshot for you. It looks like this really occurs only with Emmet. No matter what keybinding I use for that command, it always triggers the search box.


#7

According to that screenshot, Atom is doing exactly the right thing … you have Shift+B mapped to emmet:interactive-expand-abbreviation and that is what is executed when, according to your annotation in the screenshot, you press Shift+B. It even tells you that it is getting that key mapping from your keymap.cson.

What different thing are you expecting it to do in that screenshot and why?


#8

Dang, you are right. I have mistaken the command emmet:interactive-expand-abbreviation for emmet:expand-abbreviation. Thanks. Case closed.


#9

Closing this as resolved in 24 hours unless there are any objections :grinning:


#10

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.