Atom Runner-Cannot Run Python

I saw answers to this question but I think that these are not the case for me. The path seems to be correctly added and does not lead to a shortcut of the python exe or something. Unfortunately, I dont have the reputation to upload a prsc of my path configurations.

I noticed that there are 2 variables named as Path. The first one being: C:\Users\a\AppData\Local\Programs\Python\Python37 and the second one: C:\Program Files (x86)\Intel\iCLS Client

Could that be the case of the issue here? Do they conflict with each other? On the output of atom runner I can see a path thats identical to the second one from the aforementioned,does that mean that this is used instead of the correct one? How do I fix this? Any help will be highly appreciated!

New users post screenshots all the time, and there are always sites like Imgur where you can upload whatever.

So this is what I get in the output of atom-runner.

And what do the environment variables look like?

I had to post it on a separate reply cause only one picture per reply is allowed. This is the variables GUI:

Yes, you should try adding the Python path to your system Path.

It’s weird for Python to be installed in a specific user’s folder. The standard install location is at the top level of C:/.

You should also not put any code files in the Atom folder. That folder will get eliminated when Atom automatically updates, and you should never store your personal documents in an application’s directory. Keep your files somewhere you can easily rescue them if your OS stops booting.

Well on another pc python is also installed in a user’s folder and it works fine. I did not change anything in the installation, the default folder that’s shown in the install prompt is forcing for an install on that location… So u suggest that I install it on the upper level of C. I will try that and come back with the results… I will also put my python files folder on a different location, that was just a file to try if python works.

It must be a 3.7 thing. My 3.6 installation (and every Python install before that) went straight to C:/, but then when I pull up the 3.7 installer it wants to go into my user folder.

What do their environment variables look like?

So u suggest that I install it on the upper level of C.

I did not say that. You can have it installed wherever you want it. That’s not an issue.

The only thing I asked you to do was add the Python folder to your system Path. Please do not read more than the person you’re talking to has actually written. If anyone ever tries to give you an instruction through passive-aggressive commentary, just ignore it; if they can’t be bothered to tell you directly, then it’s not important. :slight_smile:

that was just a file to try if python works.

You don’t need a file for that. Just open the command line (or a package like termination) and run python -v. That is, in fact, the next thing you should do.

Well even though I added the python path on my system path it still doesn’t work.
image

Did you add the actual Python folder, or just Scripts/? Why did you add Scripts/ multiple times? Have you considered that there’s not actually a python3.exe file in the Python folder? Here’s mine:

Does your friend use the exact same configuration, with Python 3.7 and atom-runner? If so, do they have a python3.exe file?

I was ready to ask you if u could post your location of the file. I did not add it multiple times,I dont know why it shows it that way. Well, by default the path lead to scripts, I also changed it to lead to the pythonw.exe (which was simply named pythonw and i added the .exe) and still doesn’t work. image

If there’s no python3.exe, then atom-runner can’t possibly achieve what it’s looking for. You have to either reconfigure atom-runner as detailed in the package’s documentation, find a different package to use (I’m a fan of process-palette), or create a symbolic link inside the Python37/ folder that’s called python3.exe but points to python.exe.

1 Like

Well thank you!!! It actually was my laptop and I had it working fine on my desktop. I created a symbolic link using the windows command prompt exactly as you said that points to the python.exe. It now works just fine on the laptop, with no problems in the atom runner. Finally, we made it!!! :smile: So it is a problem with how atom runner searches for the .exe and how the .exe is named by the installation.

Basically. atom-runner was designed with expectations from a previous version of Python. The package hasn’t adapted to the change.

The reason for having a python3.exe file is in case you have both Python 2 and Python 3 installed on your computer. Then you can reach one with the python2 command and one with python3, and the one highest on your Path will respond to python. I assume the change was because Python 2 is gradually becoming less common.

1 Like