Atom Portable (linux) not starting from USB


#1

I have an flash drive FAT32 and wanted to have atom on it for windows and linux since im often at different pcs and different os.
The folder structure on the drive is:
/media/me/usb1/atom
|- linux
|- .atom/electronUserData
|- windows
|- projects

/windows does contain the windows files from the .zip package
/linux does contain the files from the .tar.gz package
while the portable installation in windoes works fine, linux does refuse to start from the drive eighter with permission denied from terminal since FAT does not support the executable flag of linux permissions or some weird cannot start software: Software not found when running it by doubleclicking it.
However if i copy the atom folder onto my HDD I can start it just fine. Just not on the USB.

Am I missing something important?


#2

I believe that’s the problem.


#3

Nope, vfat / fat32 simulates linux permissions.

I guess one of Linuxes reasonable security settings is in place.
External devices are not allowed to execute files.

To change this, you have to use the mount option ‘exec’
Create a new folder and mount your stick manually.

On terminal, try:

sudo mount -t vfat -o users,exec,rw,uid=1000,gid=1000 /dev/name_of_stick /path/to_new_folder

Of course, use your own uid and gid. type ‘id’ to see them.
Use ‘lsblk’ or ‘sudo blkid’ to get the dev(ice) name of your stick.
Also keep in mind, exec must come after user or users:
-o user,exec and -o users,exec are correct but -o exec,user or -o exec,users don’t work.