Atom periodically freezing


#1

Atom freezes for about 5-10 seconds every 20 seconds or so.

I’m using a 2012 retina macbook pro.

Looking at Activity Monitor, Atom Helper is jumping to 100% CPU every time the freeze happens.

I’ve googled all over, updated all software, launched in safe mode, reinstalled atom, tried atom beta. Can’t seem to solve it.

One strange thing is that it’s only on newly-created saved files. If I open an older project then the freezes don’t happen. If I create a brand new file, it’s fine until I save it, after which it bugs out.

I’ve also noticed that if I type in a new buggy file until it freezes and then switch to an old project, Atom is still responsive, and the frozen file doesn’t unfreeze until I switch back to it and wait the remainder of the 10 seconds or so.

Anyone know what could be going on here?


#2

For anyone else with this issue - I’ve found that if I copy an old non-buggy project and delete all the files, I can then work in that project without it ever freezing up. So I’ve created a template and will just copy-paste that whenever I want to create a new project. Bit weird, but it works.


Atom is super slow and is overprocessing
#3

I have the exact same issue on Windows 10.

Do you use remote FTP plugin ?


#4

I think I found a temporary fix.

  1. Navigate to folder in shell/bash/command line
  2. execute Atom from there “atom .”

The freezing didn’t occur since.


#5

Shame on me, I figured out the problem (on my side).

I had a folder .git (I created it involuntary) in a parent folder of my dev projects folders.

Periodically, atom was checking changed files in all my projects folders… so it explain everything.

Folder .git was deleted and the problem gone.


#6

I’m having the same problem. Ive toggled all my 3rd part packages, and installed the latest version of atom. But it happens at my work computer and at home. I’ve noticed it tends to happen mostly when i’m working with a SASS or .scss file. And it seems to happen most often when i’m typing a variable or start to type a variable and make a mistake. I’ve tried digging through javascript heaps and debug profiler but havent had much luck finding out whats causing it.