Atom pane not full width


#1

I’m experiencing an annoying issue where the screen isn’t full width. Included is a screenshot to illustrate. For some reason, the atom-pane element has a flex-growth property of .8xxx. But I can’t figure out where it’s coming from. Right now I’m just manually removing the property, but that of course isn’t optimal.


#2

Does this bug show up when you run atom in safe mode?


#3

Does starting atom with atom --clear-window-state fix the problem? Relevant issue perhaps https://github.com/atom/atom/issues/11673


#4

I tried what @Ben3eeE suggested because I didn’t know how to restart in safe mode:p It worked:) Thanks for the suggestion!


#5

You close all windows and type atom --safe.


#6

Thanks, I’ll keep it in mind in the future in case of funky stuff.


#7

Safe Mode won’t fix this particular problem.


#8

I just had the same problem and starting atom withatom --clear-window-state fixed it for me.


#10

This problem is caused by the command pane:decrease-size (ctrl + alt + -), you can use the command pane:increase-size (ctrl + alt + =). Finally, I think there is a bug when you decrease the size of the pane to less than 0 then the only option is to use atom --clear-window-state


#11

Wow, It’s worked! Thanks :slight_smile:


#12

This solution is way better than this one: atom --clear-window-state. Because clear-window-state screw up other custom things that I had set up in my atom.