Atom-pandoc-convert, building on Mac fail


#1

Dear all,

I am upgrading a package for atom (atom-pandoc-convert). The package builds correctly on linux but fails on mac and I have no clue what’s wrong. I attach here under the Travis log (https://travis-ci.org/josa42/atom-pandoc-convert). Any help is appreciated. Thanks

Worker information

hostname: 0ced7f54-cb7d-4572-a8e6-954e1845e334@7237.wjb-1

version: v3.10.1 https://github.com/travis-ci/worker/tree/2f4923494b1f57289a2d4b68a0861e882a7215ad

instance: 204d5abd-28c6-4dfc-b35e-8c6e9ee3e896 travis-ci-macos-10.13-xcode9.4.1-1529955246 (via amqp)

startup: 1m6.74094921s

Build system information

Build language: generic

Build id: 418219256

Job id: 418219260

Runtime kernel version: 17.4.0

travis-build version: ff4bc709c

Build image provisioning date and time

Mon Jun 25 21:55:14 GMT 2018

Operating System Details

ProductName: Mac OS X

ProductVersion: 10.13.3

BuildVersion: 17D102

Git version

git version 2.18.0

bash version

GNU bash, version 3.2.57(1)-release (x86_64-apple-darwin17)

Copyright (C) 2007 Free Software Foundation, Inc.

GCC version

Apple LLVM version 9.1.0 (clang-902.0.39.2)

Target: x86_64-apple-darwin17.4.0

Thread model: posix

InstalledDir: /Applications/Xcode-9.4.1.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin

LLVM version

Apple LLVM version 9.1.0 (clang-902.0.39.2)

Target: x86_64-apple-darwin17.4.0

Thread model: posix

InstalledDir: /Applications/Xcode-9.4.1.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin

Pre-installed Ruby versions

ruby-2.3.5

ruby-2.4.3

Pre-installed Node.js versions

v4.9.1

v5.12.0

v6.14.3

v8.11.3

mvn -version

Apache Maven 3.5.4 (1edded0938998edf8bf061f1ceb3cfdeccf443fe; 2018-06-17T18:33:14Z)

Maven home: /usr/local/Cellar/maven/3.5.4/libexec

Java version: 10.0.1, vendor: Oracle Corporation, runtime: /Library/Java/JavaVirtualMachines/jdk-10.0.1.jdk/Contents/Home

Default locale: en_US, platform encoding: UTF-8

OS name: "mac os x", version: "10.13.3", arch: "x86_64", family: "mac"

Network availability confirmed.

Fix WWDRCA Certificate

Unable to delete certificate matching "0950B6CD3D2F37EA246A1AAA20DFAADBD6FE1F75"security: AppleWWDRCA.cer: already in /Library/Keychains/System.keychain

$ rvm use

Using /Users/travis/.rvm/gems/ruby-2.4.3

git.checkout

0.54s$ git clone --depth=10 https://github.com/josa42/atom-pandoc-convert.git josa42/atom-pandoc-convert

Cloning into 'josa42/atom-pandoc-convert'...

remote: Counting objects: 61, done.

remote: Compressing objects: 100% (42/42), done.

remote: Total 61 (delta 16), reused 55 (delta 13), pack-reused 0

Unpacking objects: 100% (61/61), done.

$ cd josa42/atom-pandoc-convert

0.29s$ git fetch origin +refs/pull/28/merge:

remote: Counting objects: 25, done.

remote: Compressing objects: 100% (15/15), done.

remote: Total 25 (delta 14), reused 20 (delta 10), pack-reused 0

Unpacking objects: 100% (25/25), done.

From https://github.com/josa42/atom-pandoc-convert

* branch refs/pull/28/merge -> FETCH_HEAD

$ git checkout -qf FETCH_HEAD

Setting environment variables from .travis.yml

$ export APM_TEST_PACKAGES=""

$ export ATOM_LINT_WITH_BUNDLED_NODE="true"

$ export ATOM_CHANNEL=beta

$ bash -c 'echo $BASH_VERSION'

3.2.57(1)-release

0.07s$ curl -s -O https://raw.githubusercontent.com/atom/ci/master/build-package.sh

The command "curl -s -O https://raw.githubusercontent.com/atom/ci/master/build-package.sh" exited with 0.

0.02s$ chmod u+x build-package.sh

The command "chmod u+x build-package.sh" exited with 0.

40.32s$ ./build-package.sh

Downloading latest Atom release on the beta channel...

Using Atom version:

Atom : 1.30.0-beta2

Electron: 2.0.5

Chrome : 61.0.3163.100

Node : 8.9.3

Using APM version:

apm 1.19.0

npm 3.10.10

node 6.9.5 x64

atom 1.30.0-beta2

python 2.7.15

git 2.18.0

Downloading package dependencies...

Installing modules ✓

Missing spec folder! Please consider adding a test suite in './spec' or in './test'

The command "./build-package.sh" exited with 0.

77.84s$ npm run lint

> pandoc-convert@1.1.2 lint /Users/travis/build/josa42/atom-pandoc-convert

> eslint .

Cannot find module 'eslint-config-medikoo-es5'

Referenced from: /Users/travis/build/josa42/atom-pandoc-convert/atom/Atom Beta.app/Contents/Resources/app/apm/node_modules/es5-ext/package.json

Error: Cannot find module 'eslint-config-medikoo-es5'

Referenced from: /Users/travis/build/josa42/atom-pandoc-convert/atom/Atom Beta.app/Contents/Resources/app/apm/node_modules/es5-ext/package.json

at ModuleResolver.resolve (/Users/travis/build/josa42/atom-pandoc-convert/node_modules/eslint/lib/util/module-resolver.js:72:19)

at resolve (/Users/travis/build/josa42/atom-pandoc-convert/node_modules/eslint/lib/config/config-file.js:484:28)

at load (/Users/travis/build/josa42/atom-pandoc-convert/node_modules/eslint/lib/config/config-file.js:556:26)

at configExtends.reduceRight.e (/Users/travis/build/josa42/atom-pandoc-convert/node_modules/eslint/lib/config/config-file.js:430:36)

at Array.reduceRight (native)

at applyExtends (/Users/travis/build/josa42/atom-pandoc-convert/node_modules/eslint/lib/config/config-file.js:408:26)

at loadFromDisk (/Users/travis/build/josa42/atom-pandoc-convert/node_modules/eslint/lib/config/config-file.js:528:22)

at Object.load (/Users/travis/build/josa42/atom-pandoc-convert/node_modules/eslint/lib/config/config-file.js:564:20)

at Config.getLocalConfigHierarchy (/Users/travis/build/josa42/atom-pandoc-convert/node_modules/eslint/lib/config.js:227:44)

at Config.getConfigHierarchy (/Users/travis/build/josa42/atom-pandoc-convert/node_modules/eslint/lib/config.js:179:43)

(node:2038) DeprecationWarning: The 'parserOptions.ecmaFeatures.experimentalObjectRestSpread' option is deprecated. Use 'parserOptions.ecmaVersion' instead. (found in "standard")

npm ERR! Darwin 17.4.0

npm ERR! argv "/Users/travis/.nvm/versions/node/v6.14.3/bin/node" "/Users/travis/.nvm/versions/node/v6.14.3/bin/npm" "run" "lint"

npm ERR! node v6.14.3

npm ERR! npm v3.10.10

npm ERR! code ELIFECYCLE

npm ERR! pandoc-convert@1.1.2 lint: `eslint .`

npm ERR! Exit status 2

npm ERR!

npm ERR! Failed at the pandoc-convert@1.1.2 lint script 'eslint .'.

npm ERR! Make sure you have the latest version of node.js and npm installed.

npm ERR! If you do, this is most likely a problem with the pandoc-convert package,

npm ERR! not with npm itself.

npm ERR! Tell the author that this fails on your system:

npm ERR! eslint .

npm ERR! You can get information on how to open an issue for this project with:

npm ERR! npm bugs pandoc-convert

npm ERR! Or if that isn't available, you can get their info via:

npm ERR! npm owner ls pandoc-convert

npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:

npm ERR! /Users/travis/build/josa42/atom-pandoc-convert/npm-debug.log

The command "npm run lint" exited with 1.

Done. Your build exited with 1.