Atom over x11 forwarding with xming Errors


#1

I’m attempting to use xming with x11 forwarding. I’ve not been able to get the atom process on the linux box to actually launch over the x11 fowarding session i have open. i can do this for java apps and apps like xeyes but not atom. i do get a console message when attempting to launch “App load time: 3354ms”, I told atom to log as well “atom -l /root/atom.log” no logs are generated. I’ve tried with the new window as well.

When using the --wait i do get an error

“atom -w
/usr/bin/atom: line 117: 3907 Aborted (core dumped) nohup “ATOM_PATH" --executed-from="(pwd)” --pid=$$ “$@” > “$ATOM_HOME/nohup.out” 2>&1
App load time: 3346ms
[xcb] Unknown sequence number while processing queue
[xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
[xcb] Aborting, sorry about that.
atom --executed-from=/root --pid=3893 -w: xcb_io.c:259: poll_for_event: Assertion `!xcb_xlib_threads_sequence_lost’ failed.
Failed to get crash dump id.
Report Id:

when attempting to use the -f switch this is the messages that get generated
”[4073:0202/112011:ERROR:browser_main_loop.cc(189)] Running without the SUID sandbox! See https://code.google.com/p/chromium/wiki/LinuxSUIDSandboxDevelopment for more information on developing with the sandbox on.
[4073:0202/112016:INFO:audio_manager_pulse.cc(258)] Failed to connect to the context. Error: Connection refused
[4073:0202/112016:WARNING:proxy_config_service_linux.cc(76)] Proxy authentication parameters ignored, see bug 16709
[4073:0202/112016:WARNING:proxy_config_service_linux.cc(76)] Proxy authentication parameters ignored, see bug 16709
[4073:0202/112016:WARNING:proxy_config_service_linux.cc(76)] Proxy authentication parameters ignored, see bug 16709
App load time: 3358ms
[4073:0202/112016:ERROR:browser_main_parts.cc(115)] X IO error received (X server probably went away)”


#2

I was seeing the same error message and debugged it down to an X extension “BIG-REQUESTS”. You can use xtrace to trace all the X traffic and I saw an 8MB message before it crashed.
I first disabled all extensions with (xtrace -e ) and that worked.
My final hack was to copy libxcb.so.1 into /usr/share/atom, open up in editor, and change BIG-REQUESTS to _IG_REQUESTS. I figure when the client library asks if this extension is supported it will reply no and no more big messages.
hope this helps


#3

I’m also having this error. I have issues with my corporate windows system and want to move my dev environment to a linux box but run atom over x11.


#4

I’m also having trouble with this. I’m trying to display back from centos7 back to windows. Using Xming and X11 forwarding.


#5

ref: https://github.com/atom/atom/issues/4360

Thanks @tonywmnix - works great!

In case you’re looking for a step-by-step for @tonywmnix’s hack:

Find libxcb.so.1 (somewhere under /usr) (we’ll call it $LIBXCB)
cd /usr/local/atom
cp “$LIBXCB” .
sed -i ‘s/BIG-REQUESTS/_IG-REQUESTS/’ libxcb.so.1
Note that you may need to run the last two as sudo. Also usual disclaimer for running commands off the internet.


#6

I really wanted this to work:
$ sed -i ‘s/BIG-REQUESTS/_IG-REQUESTS/’ libxcb.so.1
sed: -e expression #1, char 1: unknown command: `▒’

The hubub on the internet is that sed doesn’t work on binary, or isn’t guaranteed to, anyway.