Atom opening as a console error (Solved)


#1

In launching atom, I am faced with a console error I don’t know how to handle. I have tried:

  • Deleting the app and reinstalling from the atom.io site

  • Restarting my computer

  • Reinstalling once more

  • Installing it on the same device but on a different disk, a windows on my mac, and it worked perfectly fine there

  • Executing atom --safe however I get : -bash: atom: command not found . I tried looking around for a solution to that but everything simply said to execute that command and it would work. Also tried going to the atom contents MacOS directory and executing it there

I am running atom version 1.17.1
and Mac OS 10.12.5

Before this problem I had not downloaded anything new such as packages for the editor, I opened up atom yesterday and was confronted by this, is all.


#2

Try renaming the ~/.atom folder, and then opening it.


#3

IT WORKED! Thank you so much it’s been frustrating me all day but now I can go back to coding !!!:smile:


#4

State information is stored in .atom, and if something gets messed up, it’s almost always that folder, not the install folder, where the problem is. Restarting also doesn’t work because the problem is the same bad data.