Atom OOM kill my LinuxMint18 session


#1

Since the last update I cannot use Atom anymore. When started it seems to spawn bash processes until I get OOMed and need to restart the complete session.

I did already reinstall Atom
I can start Atom in safe-mode (atom --safe)
I did remove all Community Packages (since I cannot disable them in safe-mode).
Even if I close of xkill Atom, the memory use keeps rising until 100%

I have no real clue as to what causes this. Should I disable and re-enable all 75 core packages?

Any other suggestions?

Version:
Atom : 1.13.0
Electron: 1.3.13
Chrome : 52.0.2743.82
Node : 6.5.0
System:
Kernel: 4.4.0-59-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.2.7 (Gtk 3.18.9-1ubuntu3.1)
Distro: Linux Mint 18.1 Serena


#2

In log-files I found a reference to Nvidia, my GPU-card.

In Systemmonitor I can see “atom -type=gpu-process …” which also references (obviously) Nvidia

However, I did not update graphic drivers before this happened.

I have not spent some hours trying different scenarios, different versions, re-installing, cleaning, restarting etc. but even 12.9 is unusable. Checked other packages, so I have no clue how to proceed.


#3

So, using atom --disable-gpu seems to work.