Atom only opens up to WebKit develop console


#1

Hi all,

Have been unable to Atom for some time on a number of machines. Have tried completely uninstalling and wiping my configuration, but to no luck (eg. How to Completely Uninstall Atom for Mac?):

https://www.dropbox.com/s/p67onin4za3ifrx/Screen%20Shot%202016-05-24%20at%2022.06.21.png

Any help appreciated!


#2

Have you tried Safe Mode? To launch Safe Mode:

  1. Completely exit all instances of Atom
  2. Launch Atom with the command atom --safe

#3

Hi,

Thanks for the response. That does work. However, this is a clean install, so doesn’t explain what would be screwing everything up. AFAIK I removed absolutely everything and did a completely clean install.

Any ideas?


#4

Hi, I got atom in that state when I tried to launch it from a reduced privilege user and Atom was not able to read it’s own config files.

Next time you see that pannel click on the red (x)1 in top rigth corner, or switch to console tab to see errors.


#5

What’s the error message in the console?


#6

Error: EACCES: permission denied, mkdir '/~'

Now if I move Atom.app to ~/Applications/ and chown to my user, I still get the error. Surely this should have fixed it?