Atom on Windows incorrectly showing files as modified (Git)


I’m just wondering if any other Windows users are having an issue with Atom showing items in the tree view as being modified. Basically when I open a project from the network Atom is showing files as modified even though they aren’t.

I created an issue a few weeks ago but no one else has chimed in with it being an issue for them.

Anyone else experiencing weird line endings like this?
Atom prompts to save file changes despite no changes done

Is it line endings? I see problems with git showing files as changed when line endings differ even though a compare doesn’t show a difference.


Check the advice here:

I agree with @mark_hahn, it is most likely line ending issues.


I think you might be right. However I can’t figure out what I need to do to fix it. I tried disabling normalization as mentioned here by adding a .gitattributes file containing “* -text” and then deleting the index file from the .git directory and doing a git reset.



@tomasjo Thanks. Still no change. I’ve tried the following but Atom still reports files as modified.

  • Tried setting core.autocrlf to true globally.
  • Tried forcing line endings to crlf by adding a .gitattributes file with “* eol=crlf” to my repository root.

I also made sure I refreshed the repository after each of the above changes.


UPDATE: I think I’ve found the problem. I navigated to the networked project via the Windows command line and did a git diff of the repo. Turns out it was file mode changes! I edited my repos’ .git/config file and set

    filemode = false

The problem now only persists for sysmlinked files. Atom (Git on Windows side) still treats these as modified.


Hi, I just encountered the same issue on my box. I tried solving it by clearing the setting at the repo level and setting it in the global git config instead. That works fine from the command line git client but Atom still shows the files as changed. Is there another place where I can set the global git config for Atom?


@Ventajou This is how I got mine to work. I think it still has a problem with symlinks but I think I can live with that for now.

On your networked linux box, edit your repository’s .git/config file and delete the filemode = True line.

Within your Windows command line set the following.

git config --global core.symlinks "false"
git config --global core.filemode "false"


Thanks, however that somehow only works for the command line git… The Atom file tree still shows me more changes as if it was looking for the git global config somewhere else…

I have the .gitconfig file in my Windows user folder, no clue where Atom’s git is looking.

Update I had to run the git config ... command from a regular command shell and it worked. Setting the config from a Powershell prompt somehow didn’t cut it. Not sure if it’s a posh-git or powershell issue…


Hey, I’m having the same issue with git subtree. I have one repository inside another, using subtree ( Atom is showing all files outside subtree as modified (and they aren’t).

This is my original issue on github:

Do you have any ideas? Where can I check on code where Atom deal with modified files?



Have you checked the other solutions listed above? I doubt that the subtree is affecting anything outside the subtree.


Hey, I just cloned my repository again and now Atom is working fine. My bad. Thank you!


You’re a godsend. This fixed it for me. Thank you!!!