Atom on OSX: how to do a @?


#1

Hi,

I have a problem with atom, newest version on MAX OSX Yosemite. I also have a swiss german
keyboard. Now, normally, on OSX with alt-g I get the @ character. Not in the atom editor though.
I tried to fix that with a custom keymap entry but failed. Probably did it wrong. The keymap
also appears rather tailored to bind commands to key rather then fix such issues.

Any help or comment?

Best Regards,

Mark Koennecke

#2

It sounds like you’re running into:


#3

Thanks,

installing that community keyboard-localization package solved the problem
for me. But I would never have guessed that I need to search for ALT problems to find that.

I suggest to distribute that package with atom by default, and announce its use publicly. There are a couple of billion people NOT using US keyboards…


#4

I doubt it counts in billions, and I doubt that every non-US keyboards have this kind of issue (I’m using a french one and the @ char has its own key). And anyway, I believe the day there’s a billion Atom users, this issue would have been fixed since long :).