Atom on macOS Catalina 10.15

Is anyone else unable to open Atom Stable or Beta or Nightly on Catalina at all? Don’t see a single mention here or on twitter so wondering if just me?

I am also having the same problem. I realize that it’s the same problem with chrome.

Downgraded to Mojave and same issue. Figured out the issue was corrupt settings. Deleting the .atom hidden folder in my home folder resolved the issue so looks like it wasn’t a Catalina issue. That is the folder seems to have got corrupted when upgrading to Catalina but had I deleted the.atom folder on Catalina pretty sure would have fixed the issue there too.

1 Like

Deleting the .atom directory did not help.

I the only think that helps is restart and start it as a first app.
Catalina disabled the x86 app support so maybe its the issue.

Atom has been exclusively a 64-bit application on macOS for years. So unless you’re using a tragically old version, that isn’t the problem.

I’m running Atom Nightly v1.42.0-nightly8 on macOS 10.15 right now and it’s working fine.

I also had this issue. Seemed that some of my development packages couldn’t be found. I fixed this by re-installing command line tools… running “xcode-select --install” in terminal. Then reinstalled Atom with Homebrew. All seems good now. Hope this helps

1 Like

That worked for me. Thanks!

I’ve been encountering some weird issues with it constantly crashing when renaming files in particular, or creating new files.

Also noticed today that every time it re-opens I’m seeing the MacOS ‘authorising Atom…’ loader bar
It’s not actually listed in apps under system preferences - security and preferences?

Sorry, to be helpful that’s “Verifying Atom” not “Authorising Atom”

After upgrading to Catalina Atom stopped working. I was able to get it working again in 2 steps:

  1. xcode-select --install
  2. removing the .atom directory

Atom opened up fine after that. I copied my Packages folder back over to the .atom directory.
I hope this helps others.

Hi,

I don’t understand, help me please

There are several tickets out covering this issue. It seems like there are many different solutions to this problem. You can read through more of them here ( https://github.com/atom/atom/issues/20034#issuecomment-564131053).

As far as my solution above goes:

  1. Open the Terminal app on your mac. Enter this in to the terminal and press return.
    xcode-select --install

  2. After xcode is done installing. Goto your Home directory on your computer and look for the .atom directory. If your “dot” files are hidden (files that start with a period ), then you will need to show those. Goto this link to learn how to do that (https://setapp.com/how-to/show-hidden-files-on-mac).

Remove the .atom directory. Then try Opening Atom again. This is all I had to do.

  • If there are plugins that you were using, install them one at a time to make sure that they aren’t causing Atom to crash. Simply uninstall any plugin that crashes Atom.

Good luck!