Atom not working in Elementary OS Juno


#1

Below is a copy/paste from a post of mine on reddit, for which I’ve received no help:

Yesterday I installed Luno on my laptop, then proceeded to successfully install Atom. Everything seemed to work fine, even managed to get some CSS coding done. When I went to turn on my laptop today, however, I noticed that when I click Atom’s icon or try to launch it from the terminal, it shows as launching on my toolbar but no window actually shows up. It’s icon just shows as being active with the blue dot beneath it, and when I click around the screen on any other window I may have open, like a Firefox, nothing happens until I select another program from my toolbar. It’s almost as if Elementary thinks Atom is launched and is taking up the entire screen.

I’ve tried uninstalling and reinstalling, but so far I’ve had no luck. Anybody have a suggestion as to what I should do?

Edit: Just tested something out. Apparently, if I manage to click on the area of my screen where Atom’s menus (File, Edit, View, etc.) would be had it launched in full screen I am literally able to make the context menu contents appear. It’s like Atom launched, but its window is invisible.

Can any of you guys figure out what I’m doing wrong? I’m driving myself mad trying to figure out what the problem is.


#2

What happens if you force Atom to quit and then start it from the command line with atom ~? If the problem is with the specific memory of the last window you had open, starting it with a new path will cause Atom to start fresh with no files open. If that doesn’t work, try atom --safe, to disable all community packages. If that doesn’t work, use atom --clear-window-state to dump all saved session memory and unsaved files and see if it shows up. If that doesn’t work, you can rename the ~/.atom/ folder, and if that doesn’t work you should try reinstalling Atom.


#4

Just got it working. A guy on Reddit gave me the following response:

have this bug too. Just launch Atom, press Win + ↑ to unmaximize window. Do not maximize it with maximize button, just resize manually.

Seems like a very weird bug. I wonder if it has anything to do with my Add-ons? Only one I have installed is an html tag finisher.


#5

Window-related issues usually have something to do with the operating system.