Atom not working for windows


#1

When I try to open atom like I normally do on my windows OS, atom does not open. I tried to open in cmd, but it’s blank when I type in atom. I tried to completely uninstalling and deleting the files from my AppData folder and the files/directories associated with atom then I reinstalled the newest update and still, it does not open. Anyone else has had this issue?

Any assistance?


#2

Have you tried renaming the .atom/ folder?


#3

As to what, should I rename the folder to?


#4

Anything you like. Explorer doesn’t like names starting with periods (but you can do it in the command line), and you should make it something you’ll remember. The important part is to start Atom without a .atom/ folder so that it creates a blank one.


#5

I’m having this issue as well. Atom appears to have randomly stopped working. Atom.exe shows up in the task manager but there is no UI. I’ve tried uninstalling/reinstalling, didn’t work.


Atom won't launch (Windows 10)
#6

Have you tried renaming .atom/?


#7

That worked. Thank you @DamnedScholar

Atom just created another .atom folder though. Will I run into the same issue again?


#8

Holy Thanos Snap

That worked! Thanks mate


#9

@Wug3d @tycooperaow

Since moving .atom/ worked, I can make an educated guess that the issue is with compile_cache/, which has been known to get corrupted from time to time. I have never seen it on my own computer in years of using Atom, but it’s an issue that’s come up on this forum before. You can move all of your packages and config files into the new .atom/ and reload Atom to have all of your stuff back where it was. The only folders you need to save are packages/ and dev/packages/, if you have anything in them. The config files are the .cson and .less files in the top level of .atom/.


#11

If this happens to you try deleting (or renaming) config.cson (C:\Users\Name.atom)

Looks like in my case it was config.cson that was causing Atom to not launch. I renamed the .atom folder to dot_atom and launched atom which created a new .atom folder. Then I copied my old /packages folder over to the new folder and that worked fine. As soon as I copied the config.cson over it stopped launching. When I opened the config.cson that didn’t work in a text editor it was blank.