Atom not starting after successful first start.. win 7


#1

Hi, this is a bit wierd…

Atom installed OK, so it seemed (win 7 ultimate 64bit), installed packages etc after initial startup.

Closed Atom… went to open it again but couldn’t find any link to it in start menu nor on desktop.

The context menu link was present, but doesn’t work, so it won’t open a file in Atom.

After using the windows ‘run’ function (Atom wouldn’t run with it), finally found the installation in the
’Appdata’ folder… not in the ‘Program Files’ folder. Anyway clicking on the file atom.exe does nothing,
except the windows task manager lists it as running under the ‘processes’ tab (not the main ‘Applications’ tab)… but Atom is nowhere to be seen!

Any ideas gratefully received… cheers,


#2

Try closing all Atom processes, renaming the .atom folder in your user directory, and then starting Atom.


#3

Thanks DS,
there’s the .atom file (which I didn’t see before) in the users folder, but the atom.exe file
is in the Appdata/Roaming/Atom file…

OK… I’ve closed the atom process that was running… created a link to it in the start menu…

Ah! it opens! but… is it supposed to install to there and not to the Program Files folder? and…

If that happens again only worse, what would I need to rename the .atom file to?


#4

Are you sure? In my experience, it’s always been in AppData/Local/atom.

OK… I’ve closed the atom process that was running… created a link to it in the start menu…

Ah! it opens!

I’ve had Atom bug on startup before, and I had to close the erroneous processes before I could proceed.

is it supposed to install to there and not to the Program Files folder?

Yes.

If that happens again only worse, what would I need to rename the .atom file to?

Anything. When Atom doesn’t find .atom, it creates a new one, and that’s how you make sure Atom runs when it’s clean.


#5

Sorry DS, I must be just too tired, not seeing straight…

Yes, the .exe file is in the ‘local’ file, but there is another atom file in the roaming file… but has other not so important stuff in it… cookies, cache of some sort, etc.

Good, it’s in the right place then.

Now I’ve lost the atom menu there was an option to hide it and now I can’t find how to find it again…

I better go to bed before something else weird happens!

Thanks DS… fantastically fast of you to reply, cheers!


#6

Found ctrl+shift+P now too… all good, thanks again!