Atom Not running smooth


#1

when i am using atom text editor it use 1 <=> 2 GB ram and my pc not working correctly when atom is running
how i can resolve this error


#2

We need more information about your situation. What version of Atom and what OS are you using? How long has this been happening? Does it happen when you start Atom from the command line with atom --safe? Does it happen when you have large files open in Atom, or also when you don’t have large files open?


#3

latest version of atom
windows 10
and what is mean by atom --safe


#4

Hello.

<sarcasm = on> …so you must be running V1.23 alpha? <sarcasm = off>
Please never say that. State clearly which version you are running.

Have a look at The Flight Manual focus on Debugging, more specifically Using safe mode. Activating safe mode is important for diagnosing your problem.

Thereafter…
Do you know which packages you have installed? Do you know how to disable them? If you know, I suggest you disable all packages to do with Git or Github and see if there is any change.

Also…
See if you can make a plan to make a screen capture and publish it somewhere where we can reach it. Sometimes this can give the guys a clue too.

Good luck.
- Dan