Atom not responding with 10.14.0


#1

At first and sometimes thereafter there is a long pause after I type before it appears. The message “atom not responding” appears and then immediately it starts working. An irritant. Anything to do other than wait for an update from apple?


#2

Some questions for you:

  • What version of Atom are you running?
  • Do see you the same behavior in safe mode?
  • Have you tried any of the other debugging suggestions?
  • Do you see this behavior only with a particular project (or file?) open or do you see it with any/no project open?
  • You didn’t see this behavior before Mojave but once you updated, you started seeing this behavior?

#3

1.31.1 x64
No haven’t tried anything, just started after upgrading to Mojave. Since it comes around after maybe 30 seconds, I’m assuming its due to the Mojave upgrade, just reporting for the record. But if it doesn’t resolve I’ll spend some time trying to debug. It happens in all files.

Thanks


#4

Ok sounds good - if it doesn’t resolve, I would definitely try safe mode, resetting to factory defaults, and clearing saved state (note that you’ll lose unsaved data when clearing saved state).

Let us know how it goes :v: