Atom not opening folders/saving new files/doing anything


#1

Hello, new to this forum, so I hope I’m not breaking any rules. I’ve had this issue for a few days, and I haven’t been able to find anything for it. I believe I had two files open in atom when my computer restarted for a major update. When the update was finished, I opened atom, and it prompted me to recover those two files as if they weren’t saved correctly. Even if I tried to restore the newest version of the file and save it, it wouldn’t save. I get a yellow error
"EEXIST: file already exists, mkdir
’’"
This happens for new files and those two files that were open when I restarted my computer. Since then, I’ve tried to uninstall and reinstall a few times. One time while uninstalling, I looked for any files that weren’t uninstalled and I deleted them (although I may have missed some). Atom still doesn’t work, but it has since stopped prompting me about those two files. It just opens to an empty, inoperable window that looks like the attached picture.

Running a windows 10 insider preview.

Copy and paste of the console (ctrl+shift+i):
:30631 Uncaught (in promise) TypeError: this.buffer.registerTextDecorationLayer is not a function
at new TokenizedBuffer (C:\Users\dgatl_000\AppData\Local\atom\app-1.18.0\resources\app\src\tokenized-buffer.js:59:46)
at new TextEditor (C:\Users\dgatl_000\AppData\Local\atom\app-1.18.0\resources\app\src\text-editor.js:217:38)
at TextEditorRegistry.build (C:\Users\dgatl_000\AppData\Local\atom\app-1.18.0\resources\app\src\text-editor-registry.js:145:20)
at C:\Users\dgatl_000\AppData\Local\atom\app-1.18.0\resources\app\src\workspace.js:1378:48

Thank you for any help


#2

Edit: It looks like I can open folders just fine outside of my OneDrive. Other directories like an external card of Documents are just fine. Also, when I try to search packages, it says it couldn’t find any. It almost seems like Atom isn’t connecting to the internet.


#3

Have you been able to open files in your OneDrive before?

Is this in the Packages tab or the Install tab?


#4

The Install tab. However, since I posted this, the Install tab seems to run just fine. I have no idea what’s changed. Perhaps this was unrelated

Up until the update, I was doing all my work in my OneDrive folder ie.
Users\Me\OneDrive
However, now, when I try to open anything in OneDrive, it gives me the same blank screen. I then proceeded to copy the entirety of my OneDrive to my Dropbox, and voila, I’m back in business.

When I click open new folder and then open Users\Me, OneDrive doesn’t show up as a subfolder, but Dropbox does. However, I have double checked that both are in fact in Users\Me. Perhaps Atom isn’t seeing my OneDrive folder like it should?


#5

I have no idea. I’ve never used OneDrive, so I have no experience with it.