Atom not loading packages when open new file?


I have these packages atom-beautify, autocomplete, suggestions and more. They do not load when I open a new file. Just when I close Atom and leave the files there and open Atom again I have all the packages working. I want them to working when I open the file.For example, I create a new file main.html and try to put there a snnipet it won’t work the suggestion will not pop up. To make it work I need to leave the file open then close atom and open again. Another example I make a CSS file and try to put code but the suggestion box does not pop up, just after I close Atom and open Atom again it works.


So when you have Atom open and the packages are working, then you create a new file, they all stop working? Do they stop working everywhere, or just in that new file?


Just the new file if I close Atom and leave the newfile in tab and open Atom again then Atom see it.


I can open files same behavior, It works only if I have them open and close Atom and open Atom again.


Has this always happened? What version of Atom are you running? Does it make a difference whether the newly opened file is in a pending tab or not? (Pending tabs have their names in italics, and if you open a new file the pending tab is closed.)


Atom is 1.31.1, don’t know what you mean with pending tab. For example I open files from project in tabs, if I try to put a snippet it wont pop up the suggestion box .Only if I close atom and open again.Atom remembers the open tabs and then it works for those files, if I open other wont, I need to close again lol.


Has this always happened?


I open new file packages not load, only when I close Atom and open again with the files open in tab then it works.I think atom just once see the files from start.


This is when I open a file :

An here is when I leave open file and close Atom and open Atom:

You see all the packages are loaded now, If I try to open again other file it wont work just the files when I Open Atom


Was there a time before this issue appeared or has this always happened?


Don’t know exactly, I think always happened, I leave update auto with Atom so it updates alone.Should I get other version ? Or maybe I uncheck something and Atom do not load packages when I open new files.


Atom loads packages when it opens. I have no idea why some of them aren’t working when you open a new file. You can verify that a package is loaded by typing atom.packages.getActivePackage('autocomplete-plus') into the developer tools console (ctrl-shift-i).

What happens when you try to use atom-beautify in a newly-opened file? Do you get any errors in the console?


When I open a file, In the console I see this error, don’t know if is the problem or something else.
Uncaught (in promise) Cannot get services before activation

I think something about node_modules


Please post a screenshot of the error.



I’ve never seen anything like this, but I think I understand what’s not happening right. I just don’t know why or how to fix it.

Try closing Atom completely, then opening the command prompt window and running atom --safe and tell me if it still happens. If it does, then try downloading the latest installer, deleting the folder C:/Users/Adrian/AppData/Local/atom, and reinstalling.


I try with atom --safe and It Works, when I open new files the suggestion box pop up now.But with Atom safe all the packages are gone I think .So Is a problem with the packages ? Does Atom use nodejs ? Because I have a new version.


In safe mode, all community packages are disabled. This suggests that one of the packages you have installed is causing an issue. If you post a list of packages you have installed (you can pull it up pretty quickly with the command apm ls in the command prompt), I can help you try to figure out which ones are the most likely culprits.

Atom uses a version of Node that’s built into it when it’s compiled. You do not need a specific version unless you are building Atom from source code.


├── advanced-open-file@0.16.8
├── ask-stack@2.2.0
├── atom-beautify@0.33.4
├── atom-debug-ui@1.0.4
├── atom-ide-ui@0.13.0
├── atom-notes@1.19.7
├── atom-shortcuts@0.0.2
├── atom-wrap-in-tag@0.6.0
├── blade-snippets@0.2.0
├── busy-signal@1.4.3
├── color-picker@2.3.0
├── cursory-glance@0.1.0
├── emmet@2.4.3
├── file-icons@2.1.25
├── fonts@3.1.0
├── goto-definition@1.3.4
├── highlight-selected@0.14.0
├── ide-css@0.3.0
├── ide-html@0.4.2
├── ide-php@0.7.15
├── ide-typescript@0.7.6
├── ide-vue@0.1.9
├── intentions@1.1.5
├── language-blade@0.41.4
├── language-vue@0.23.1
├── php-cs-fixer@4.1.1
├── pigments@0.40.2
├── release-notes@0.53.0
├── remote-ftp@2.2.0
├── set-syntax@0.4.0
├── symbol-gen@1.3.1
├── sync-settings@0.8.6
└── tree-view-git-status@1.5.2

I have some packages…Should I try to disable one by one and see who’s the culprit ?


Yes, and you can begin at the packages most likely to cause an issue like this, starting with advanced-open-file. Some of them are very simple and don’t interact at all with the part of the process that’s going wrong, such as pigments and busy-signal, so you don’t have to check those unless you get through everything else.