Atom not installing on 32 bit ubuntu


#1

Followed the ppa install instructions for ubuntu 12.04 32 bit OS as follows

 sudo add-apt-respository ppa: webupd8team/atom
sudo apt-get update
sudo install atom

I now get the following message:

Package atom not available, but is referred to by another package. This may mean that the package is missing , has been obsoleted, or is only available from another source.

I though this was the installation for 32 bit systems?

Any other options?


#2

From the Atom README:

Debian Linux (Ubuntu)

Currently only a 64-bit version is available.

So, I’m not sure what instructions you’re referring to?


#3

This article is referring to both 64 and 34 bit :

Thanks for any info


#4

I’d recommend following the instructions for building on Ubuntu, which can be found here:


#5

I get the following failure and error when I follow the instructions on git hub for installing atom.
I tried to install atom-shell separatedly, and succeeded but the build script uninstalled it. I noticed also, that atom-shell has changed to electron. Likewise, i installed electron only to have the build script uninstall it so it could fail for not haveing atom-shell.

$ sudo script/build
Node: v0.10.15
npm: v2.5.1
Installing build modules…
Installing apm…
Installing modules ✓
Deduping modules ✓
Running “download-atom-shell” task
>> Cannot find atom-shell v0.22.3 from GitHub [Error: Not Found]
Aborted due to warnings.


#6

atom-shell has been renamed electron, maybe that’s the problem? Maybe you can pull a newer versionn and try again?


#7

Will there be a 32-bit Ubuntu build available soon? I’ve never had much luck building complex things from source code.


#8

To my knowledge, there are no plans for an official 32-bit Ubuntu build.


#9

Hello, I would like to up this thread.
Today I tried to build from sources atom on ubuntu 14.04 LTS 32-bit.
Everything was just fine but atom running is just a white box, a bit hard to kill.
Is it a common/known problem? Can it be fixed?
Maybe it is my fault. I started with the idea it could be done, now I’m not so sure Ubuntu 32-bit can afford atom.
Any help appreciated.
JJ