ATOM not installing correctly on MAC Sierra


#1

'm using MAC with Sierra ver 10.12.6 and ATOM is not launching. I download ATOM and the file seems to unzip. I can not do anything with ATOM. The application menu only shows Atom. When I click on Atom all I can select is “Quit”. Can you tell me what I need to do to get it to work or what have I done wrong?


#2

Can you share what happens when you try to start Atom in safe mode from Terminal?

atom --safe

Also, can you share a screenshot of this:

When I click on Atom all I can select is “Quit”.


#3

53-PM


#4

I have the same issue: latest version of Atom from the website, OS El Capitan 10.11.6 on a Mac Pro early 2009.
atom -safe creates the exact same result.

On my Mac Pro with Sierra Atom works just fine …


#5

Hmmm, if you start Atom like this, is there any output?

atom -f --safe

Also, does temporarily resetting to factory defaults help?

http://flight-manual.atom.io/hacking-atom/sections/debugging/#reset-to-factory-defaults


#6

This is what I get with atom -f --safe:

[1763:0901/103206.778129:WARNING:dns_config_service_posix.cc(152)] dns_config has unhandled options!
2017-09-01 10:32:07.020 Atom[1763:34658] EEXIST: file already exists, mkdir '/Users/…/.atom’
2017-09-01 10:32:07.029 Atom[1763:34658] Error: EEXIST: file already exists, mkdir '/Users/…/.atom’
at Object.fs.mkdirSync (fs.js:855:18)
at Function.sync (/Applications/Atom.app/Contents/Resources/app/node_modules/mkdirp/index.js:71:13)
at Proxy.makeTreeSync (/Applications/Atom.app/Contents/Resources/app/node_modules/fs-plus/lib/fs-plus.js:385:23)
at Config.module.exports.Config.initializeConfigDirectory (/Applications/Atom.app/Contents/Resources/app/src/config.js:438:10)
at Config.module.exports.Config.load (/Applications/Atom.app/Contents/Resources/app/src/config.js:423:12)
at new AtomApplication (/Applications/Atom.app/Contents/Resources/app/src/main-process/atom-application.js:117:19)
at Function.module.exports.AtomApplication.open (/Applications/Atom.app/Contents/Resources/app/src/main-process/atom-application.js:61:9)
at App. (/Applications/Atom.app/Contents/Resources/app/src/main-process/start.js:71:21)
at emitTwo (events.js:111:20)
at App.emit (events.js:191:7)


#7

Moving the user .atom directory worked for me!
Atom behaves now as expected.
So, I need to check with option or setting creates this issue in my old config.


#8

Glad that worked for you - one thing you can also try is clearing saved state (note that any unsaved work will be lost if you use this functionality):

http://flight-manual.atom.io/hacking-atom/sections/debugging/#clearing-saved-state

So you can use your old .atom directory and try clearing saved state to see if that helps.