Atom not appearing in programs or on start menu

I’m wondering if anyone can help me figure out why Atom is not appearing in my programs or start menu.

I previously had Atom installed on my computer and had no issues with it, but recently I had to reset Windows. The other day I re-downloaded and installed Atom from atom.io. After it finished installation it opened like it usually does, but not on the welcome screen (which I didn’t notice at the time, but now seems strange). I closed it out and when I went to reopen Atom I could not find it in my start menu or search for it.

I uninstalled Atom and reinstalled it (this time I downloaded the file using Chrome, instead of Opera which I’d used the first time). It again opened on installation and with the welcome screen, but still does not appear in start.

I’ve spent the last couple of days trying to troubleshoot and debug this, but haven’t gotten far. I was able to add “Open with Atom” to context menus using the settings in Atom, which at least gives me a work around to be able to use it. I tried to complete the debugging steps outlined in the documentation but atom doesn’t show up in command line either. I get this error:

‘atom’ is not recognized as an internal or external command,
operable program or batch file.

Does anyone have any suggestions on what I should do next?

Hi @sjustus,

This is a known issue with the Atom installer https://github.com/atom/atom/issues/14020. As a workaround you can navigate to the %LOCALAPPLDATA%\atom folder to find the atom.exe file and manually add the shortcuts you want.

To make Atom recognized as a program in the command line you can try this:

  1. Open cmd.exe
  2. Navigate to the Atom install folder using cd %LOCALAPPLDATA%\atom
  3. Run atom --squirrel-updated

This will create the necessary folders and recreate registry/path associations.

Source for this workaround is here: https://github.com/atom/atom/issues/11450#issuecomment-233866304

Aha! I finally got it–thanks!

I cannot find Atom.exe under %LOCALAPPLDATA%\atom

What is in that folder? A screenshot would be appreciated.

Thanks it’s working now. I am using Windows 10. Opened Windows file explorer and pasted this `%USERPROFILE%\AppData\Local’ now I am able to see it.

Thanks for your help.

1 Like

Okay so if atom is not creating a shortcut in start menu or desktop , its because Atom is installed in a hidden folder inside C://users/local/appdata . To see the hidden folder you can google the procedure and after that go to the local folder inside the appdata folder and then to the atom folder where you can see the atom application . I AM SURE THIS WILL HELP.

Hi binoysmall, I just login here to thanks you for got the quick solution from you. Thanks. It works. Thanks to all who drag the topics here.

I am new atom user.

I’ve installed atom but it is not visible in laptop what should i do