Atom no longer runs in Windows


#1

Just updated to Atom 1.0.19 and Atom runs, but when it gets to loading anything (tabs, menu) it just sits there until it asks me if I want to close or “keep waiting”. No amount of waiting actually brings anything up.

I attempted to uninstall using Windows Control panel programs menu, then reinstall. This did not help.

Going in and attempting to run an older version of Atom does not work either (I tried running 1.0.16).

Setting up Atom takes a bit of time so wiping everything and starting from scratch seems like too much of a pain in the butt, is there anything else I can do?


#2

Have you followed the suggestions in the Debugging document? Also, could you give the following information?

  • What version of Windows are you running?
  • Do you have Emmet installed?
  • Can you reproduce the issue after completely exiting Atom and restarting using atom --safe?

#3

I was able to run once I opened a second copy of Atom while it was trying (and failing) to load the first. This prevented settings from opening in my new window (which is I believe where it seemed to hang) and then I was able to kill the other window, then run normally. I’m not sure how this fixed anything, but it worked.

After checking Timecop after opening I noticed how crazy Emmet is on performance on startup and decided that since I no longer use Atom for things that I would use Emmet for (sorry to say I had to switch back to Sublime for this type of stuff), I disabled Emmet and another community package (save-session) that was causing an error and things seem to be running smoothly enough now.