Atom.live package not working


#1

When ever I try to rum my HTML codes live it says network error.


#2

What package are you using? Please give us the exact name that appears when you pull up that package under the Packages tab.


#3

I am using atom-live-server.

This site can’t be reached
127.0.0.1 refused to connect.
Try:

Checking the connection
Checking the proxy and the firewall
ERR_CONNECTION_REFUSED

This is what it says in my browser whenever I try run live server.


#4

Please walk me through the steps you are taking to activate the atom-live-server package.


#5

Hello, I am experiencing the same error.

I originally did this on my Dell Inspiron 5900 series.

I just went into Settings\Install\atom-live-server and then installed it and I ran the code I had in the file.

The code was the Google Maps JavaScript API, autocomplete and directions code sample. It worked fine.

Now, I am trying the same thing on my HP and it’s giving me the error:127.0.0.1 refused to connect.

To test it, I utilized a code sample from https://templated.co/ and it loaded everything fine with no error.

So I am confused and I am pretty new to all this programming stuff.


#6

So the Google Maps call from your HP always fails, but other code works? What about other code that makes calls to other APIs?


#7

Yes, other code code works.

No,I haven’t tried code that calls to other APIs.


#8

That’s the open question for me. If it’s the combination of the HP and API calls in general, then something is probably different about the path between the computer and the network.


#9

@DamnedScholar I was able to resolve the issue.

I noticed that the version of Github on my Dell computer was 1.24.0 while the version on my HP was 1.25.0.

I had a similar issue when I was trying to set up the create-react-native app.

I downloaded the latest version of node.js/npm and the create-react-native app wouldn’t work.

After watching a video on the set-up, I noticed the person downloaded the stable release, not the latest release. I did the same and it worked.

The HP had the latest version of Atom so I thought it was the same error.

I downloaded the 1.24.0 version which was released in February and the API worked just as it did when I first tried it in February on the Dell laptop .