Atom lags when typing or scrolling and eating away memory


#1

Since the beginning of June I had some problems with atom, it lags for a couple of seconds when I scrol or type. Eating away my memory, mostly 3GB but it once ate 20GB! I tried running it in safe mode, but lagging keeps happening. I’m running a 2015 MBP 16GB RAM 2,2GHz intel I7

Has anyone any thoughts?


#2

Does it consume this much memory when you don’t have any files open? What about when you open Atom from the command line with atom --safe?


#3

There where around 5 files open. And yes I opened atom with atom --safe and the lag is the same.


#4

:thinking: It would be interesting to see what result comes
from installing a portable installation of Atom V1.20 Beta7.
V1.20 Beta “feels” better.


#5

Tried it yesterday, the lag keeps happening


#6

This does not sound healthy at all.
Did you do an <empty> <portable> installation?
Empty… as in no packages; a portable package directory that is empty.

  • Could you tell us some more about your install environment (example: which OS).
  • Have you yet used a resource metering application to see where the bottleneck is?
  • How is the state of your battery and how hot does your PC become?
    (…I had this problem on an assignment in the Middle East.)

#7

When you look at the status bar, there’s an item that indicates the number of files being tracked by the built-in github package. How many do you see?


#8

I tried to run the beta in a empy installation and it still keep happening.

I’m currently running OSX El Capitan 10.11.6
I’ve recorded a javascript CPU profile and this came up when there was the ‘lag’.

My battery is 100% and my MBP becomes quite hot


#9


#10

Okay, that’s one more thing we can rule out. There have been a few Mac users who have had performance issues due to their home folders being somehow made into git repos (so they had six figures’ worth of files being tracked).

I have no idea what’s going wrong, but we’ve ruled out a few things.

  1. It’s not a package or your init.coffee file (because safe mode didn’t help).
  2. It’s not a fault with your specific version of Atom (because changing versions didn’t help).
  3. It’s not your files unless one of the files you’re working with is extremely long (because you’re not working with too many).

Unfortunately, neither @danPadric and I use Macs, so there may be an avenue of investigation that we’re forgetting.


#11

I’ve experienced the exact same lag (Mac OS 10.12.6/Sierra, Atom 1.19.5 x64). The project I have open is a Git repo, but my home directory is not. The lag was so severe (1-2 seconds to scroll down a few hundred lines of code) that I ended up switching to VS Code, which (for me) is much more performant. Would love to switch back if I can sort this out…


#12

Just after firing up Atom in Ubuntu, it’s idling at 1Gb of RAM. My machine has 4Gb.

It’s a very promising editor, but because of these resource demands, I’ve switched to Emacs + Spacemacs, until the memory problem is addressed.
Sublime and Emacs use less than 256Mb of RAM.


#13

What you’re seeing is unusual. I have several Atom windows open (one of which has been open for days) and none of them are over 500Mb.


#14

I’m having the same issues after upgrading from 1.18 to 1.19, and 1.20 has the same issues. Scrolling, switching tabs, cmd+p, moving a virtual desktop with atom full screen… they all lag. Disabling the Github panel, and atom --safe didn’t make a difference. I went back to 1.18, and no more lag. This is on macOS Sierra 10.12.3.


#15

Did you disable the github package itself, or just the dock item? It’s a core package, so --safe doesn’t turn it off.


#16

@DamnedScholar, yup, I did disable the package. I also removed atom completely and reinstalled it, and same issue.


#17

@aaronisrael - just to be 100% about it, can you disable the GitHub package temporarily and see if that helps? And if you still have that CPU profile you recorded laying around or if you can record a new one when you see the lag again, can you save it and share it with us (e.g. through some file sharing service, I don’t believe you’ll be able to attach it)? Or feel free to email it to atom@github.com if that’s easier for you.


#18

@klokie - did you also give it a try in safe mode (atom --safe) to rule out any community packages?


#19

Hi,
for some reason it is all fixed now. Idk how, but it doesn’t lag anymore


#20

@aaronisrael, any ideas what could have fixed it? I am still having lag everywhere on the latest version. I even tried the beta, and same thing.